summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Luttringer2021-04-19 00:12:34 +0200
committerSébastien Luttringer2021-04-19 00:12:34 +0200
commitb5ae93a1b7839fa572f0d944d8158ba69235919f (patch)
tree8783103ee6d63076a86c755738c7c07d68ffaee2
downloadaur-b5ae93a1b7839fa572f0d944d8158ba69235919f.tar.gz
Move from [community]
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
-rw-r--r--ferm.service15
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..474245844121
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ferm
+ pkgdesc = Tool to maintain complex firewalls
+ pkgver = 2.5.1
+ pkgrel = 1
+ url = http://ferm.foo-projects.org/
+ arch = any
+ license = GPL2
+ depends = iptables
+ depends = perl
+ optdepends = ebtables
+ optdepends = arptables
+ optdepends = ipset
+ backup = etc/ferm.conf
+ source = http://ferm.foo-projects.org/download/2.5/ferm-2.5.1.tar.xz
+ source = http://ferm.foo-projects.org/download/2.5/ferm-2.5.1.tar.xz.sig
+ source = ferm.service
+ validpgpkeys = 0392335A78083894A4301C43236E8A58C6DB4512
+ md5sums = 6d14d9e5e672885bc6f2fceafbf2942f
+ md5sums = SKIP
+ md5sums = 9c5ece2628fd86a73b70f9c39df63e9f
+
+pkgname = ferm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71427b891121
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Sébastien Luttringer
+# Contributor: Marti Raudsepp <marti@juffo.org>
+# Contributor: Manuel Mazzuola <origin.of@gmail.com>
+
+pkgname=ferm
+pkgver=2.5.1
+pkgrel=1
+pkgdesc='Tool to maintain complex firewalls'
+arch=('any')
+url='http://ferm.foo-projects.org/'
+license=('GPL2')
+depends=('iptables' 'perl')
+optdepends=('ebtables' 'arptables' 'ipset')
+backup=("etc/$pkgname.conf")
+validpgpkeys=('0392335A78083894A4301C43236E8A58C6DB4512') # Max Kellermann <max@blarg.de>
+source=(
+ "http://ferm.foo-projects.org/download/${pkgver:0:3}/$pkgname-$pkgver.tar.xz"{,.sig}
+ "$pkgname.service")
+md5sums=('6d14d9e5e672885bc6f2fceafbf2942f'
+ 'SKIP'
+ '9c5ece2628fd86a73b70f9c39df63e9f')
+
+package() {
+ # software setup
+ cd $pkgname-$pkgver
+ make PREFIX="$pkgdir/usr" install
+ cd "$pkgdir"
+ # setup default config
+ install -D -m 644 usr/share/doc/ferm/examples/workstation.ferm etc/$pkgname.conf
+ # remove fancy docs
+ rm usr/share/doc/ferm/ferm.{html,txt}
+ # /usr merge
+ mv usr/sbin usr/bin
+ # systemd
+ install -Dm 644 "$srcdir/$pkgname.service" usr/lib/systemd/system/$pkgname.service
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ferm.service b/ferm.service
new file mode 100644
index 000000000000..253715dfcaeb
--- /dev/null
+++ b/ferm.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=for Easy Rule Making
+After=ipset.service
+Before=network-pre.target
+Wants=network-pre.target
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=/usr/bin/ferm /etc/ferm.conf
+ExecReload=/usr/bin/ferm /etc/ferm.conf
+ExecStop=/usr/bin/ferm -F /etc/ferm.conf
+
+[Install]
+WantedBy=multi-user.target