summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-12-14 14:25:16 -0500
committerAndrew Sun2019-12-14 14:25:16 -0500
commit728322beafd73a38449e3c37acb1459d653e34c7 (patch)
tree5412941070ad763a9ed326dac30c2b0c5861c998
parentff44ad79098422909f1d177a1ece1898dbe4f99a (diff)
downloadaur-728322beafd73a38449e3c37acb1459d653e34c7.tar.gz
fern-wifi-cracker: update to 3.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
-rw-r--r--fern-wifi-cracker.install3
3 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50da70b1f732..4a0d2e983735 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = fern-wifi-cracker
pkgdesc = WEP, WPA wifi cracker for wireless penetration testing
- pkgver = 2.7
+ pkgver = 3.0
pkgrel = 1
url = https://github.com/savio-code/fern-wifi-cracker
+ install = fern-wifi-cracker.install
arch = any
groups = blackarch
groups = blackarch-cracker
groups = blackarch-wireless
license = GPL2
- makedepends = unzip
- depends = python2
- depends = python2-pyqt4
+ depends = gksu
+ depends = python
+ depends = python-pyqt5
depends = aircrack-ng
depends = xterm
depends = subversion
depends = scapy
depends = macchanger
- depends = gksu
conflicts = fern-wifi-cracker-git
replaces = fern-wifi-cracker-git
- source = https://github.com/savio-code/fern-wifi-cracker/archive/v2.7.zip
- sha1sums = SKIP
+ source = fern-wifi-cracker-3.0.tar.gz::https://github.com/savio-code/fern-wifi-cracker/archive/v3.0.tar.gz
+ sha256sums = b4b07f719ee91e7d3b37044cf8a8d4dabf0decce9124db4402eb27b93479252f
pkgname = fern-wifi-cracker
diff --git a/PKGBUILD b/PKGBUILD
index 61b45a5633ea..a6627005db3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,35 @@
-# Maintainer Paul Sajna <sajattack@gmail.com>
+# Maintainer: Andrew Sun <adsun701 at gmail dot com>
+# Contributor: Paul Sajna <sajattack at gmail dot com>
-pkgname='fern-wifi-cracker'
-pkgver='2.7'
+pkgname=fern-wifi-cracker
+pkgver=3.0
pkgrel=1
groups=('blackarch' 'blackarch-cracker' 'blackarch-wireless')
pkgdesc='WEP, WPA wifi cracker for wireless penetration testing'
arch=('any')
url='https://github.com/savio-code/fern-wifi-cracker'
license=('GPL2')
-depends=('python2' 'python2-pyqt4' 'aircrack-ng' 'xterm' 'subversion' 'scapy'
- 'macchanger' 'gksu')
-makedepends=('unzip')
+depends=('gksu' 'python' 'python-pyqt5' 'aircrack-ng' 'xterm' 'subversion' 'scapy'
+ 'macchanger')
replaces=('fern-wifi-cracker-git')
conflicts=('fern-wifi-cracker-git')
-source=("https://github.com/savio-code/fern-wifi-cracker/archive/v$pkgver.zip")
-sha1sums=('SKIP')
-
-prepare() {
- unzip v$pkgver.zip
- cd "$srcdir/$pkgname-$pkgver/Fern-Wifi-Cracker"
-}
+install="${pkgname}.install"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/savio-code/fern-wifi-cracker/archive/v${pkgver}.tar.gz")
+sha256sums=('b4b07f719ee91e7d3b37044cf8a8d4dabf0decce9124db4402eb27b93479252f')
package() {
cd "$srcdir/$pkgname-$pkgver/Fern-Wifi-Cracker"
mkdir -p "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/usr/share/fern-wifi-cracker/Settings"
+ mkdir -p "$pkgdir/usr/share/fern-wifi-cracker"
cp -a --no-preserve=ownership * "$pkgdir/usr/share/fern-wifi-cracker"
cat > "$pkgdir/usr/bin/fern" << EOF
#!/bin/sh
cd /usr/share/fern-wifi-cracker
-exec python2 ./execute.py "\$@"
+exec python execute.py "\$@"
EOF
- chmod +x "$pkgdir/usr/bin/fern"
+ chmod 755 "${pkgdir}/usr/bin/fern"
}
diff --git a/fern-wifi-cracker.install b/fern-wifi-cracker.install
new file mode 100644
index 000000000000..611faba994f4
--- /dev/null
+++ b/fern-wifi-cracker.install
@@ -0,0 +1,3 @@
+post_remove() {
+ rm -rf "/usr/share/fern-wifi-cracker"
+}