summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2020-03-22 13:58:15 -0400
committerGI_Jack2020-03-22 13:58:15 -0400
commitfd5589cf8237cc184641583a8a5871dc8b9493c8 (patch)
tree1c31b73888ca784c3877721a6e75bd5653606bc8
downloadaur-fd5589cf8237cc184641583a8a5871dc8b9493c8.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b81a003b8aab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ferrite-core
+ pkgdesc = Ferrite Core DX font family by Froyo Tam(Meta-package with TTF and OTF variants)
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/froyotam/ferrite-core/
+ arch = any
+ license = Custom
+ conflicts = ttf-ferrite-core-git
+ source = otf-ferrite-core-2.0.tar.gz::https://github.com/froyotam/ferrite-core/archive/2.0.tar.gz
+ sha256sums = 3ecd9c181e746bd2b92c5fc429cfb0a3a61456637ab5a5d6d4d46dd0ca96c7ba
+
+pkgname = otf-ferrite-core
+
+pkgname = ttf-ferrite-core
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..332ea1a80767
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
+
+pkgbase="ferrite-core"
+pkgname=("otf-${pkgbase}" "ttf-${pkgbase}")
+_pkgname=ferrite-core
+pkgver=2.0
+pkgrel=1
+pkgdesc="Ferrite Core DX font family by Froyo Tam(Meta-package with TTF and OTF variants)"
+arch=('any')
+url="https://github.com/froyotam/ferrite-core/"
+license=('Custom')
+conflicts=("ttf-ferrite-core-git")
+install=
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/froyotam/ferrite-core/archive/${pkgver}.tar.gz")
+noextract=()
+sha256sums=('3ecd9c181e746bd2b92c5fc429cfb0a3a61456637ab5a5d6d4d46dd0ca96c7ba')
+
+package_ttf-ferrite-core() {
+ cd "${_pkgname}-${pkgver}"
+ install -Dm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 fonts/ttf/FerriteCore-Regular.ttf "${pkgdir}/usr/share/fonts/TTF/FerriteCore-Regular.ttf"
+ install -Dm644 fonts/ttf/FerriteCoreDX-Regular.ttf "${pkgdir}/usr/share/fonts/TTF/FerriteCoreDX-Regular.ttf"
+ install -Dm644 fonts/ttf/FerriteCoreDX-Medium.ttf "${pkgdir}/usr/share/fonts/TTF/FerriteCoreDX-Medium.ttf"
+ install -Dm644 fonts/ttf/FerriteCoreDX-Light.ttf "${pkgdir}/usr/share/fonts/TTF/FerriteCoreDX-Light.ttf"
+ install -Dm644 fonts/ttf/FerriteCoreDX-Display.ttf "${pkgdir}/usr/share/fonts/TTF/FerriteCoreDX-Display.ttf"
+ install -Dm644 fonts/ttf/FerriteCoreDX-Black.ttf "${pkgdir}/usr/share/fonts/TTF/FerriteCoreDX-Black.ttf"
+}
+
+package_otf-ferrite-core() {
+ cd "${_pkgname}-${pkgver}"
+ install -Dm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 fonts/otf/FerriteCore-Regular.otf "${pkgdir}/usr/share/fonts/OTF/FerriteCore-Regular.otf"
+ install -Dm644 fonts/otf/FerriteCoreDX-Regular.otf "${pkgdir}/usr/share/fonts/OTF/FerriteCoreDX-Regular.otf"
+ install -Dm644 fonts/otf/FerriteCoreDX-Medium.otf "${pkgdir}/usr/share/fonts/OTF/FerriteCoreDX-Medium.otf"
+ install -Dm644 fonts/otf/FerriteCoreDX-Light.otf "${pkgdir}/usr/share/fonts/OTF/FerriteCoreDX-Light.otf"
+ install -Dm644 fonts/otf/FerriteCoreDX-Display.otf "${pkgdir}/usr/share/fonts/OTF/FerriteCoreDX-Display.otf"
+ install -Dm644 fonts/otf/FerriteCoreDX-Black.otf "${pkgdir}/usr/share/fonts/OTF/FerriteCoreDX-Black.otf"
+}