summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-23 09:36:15 +0800
committerzxp198210052024-01-23 09:36:15 +0800
commitb6813c6e1d43b14addbd1a5b623056ada0519439 (patch)
treea291c4f3c166af1aeed78304513713dc058b060b
parent2b52f0362ed3d439be9142815423bf900429214a (diff)
downloadaur-b6813c6e1d43b14addbd1a5b623056ada0519439.tar.gz
update to 0.17.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD12
-rw-r--r--ferrum.sh8
3 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 688e5e48d2a9..f3c57612d221 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = ferrum-bin
pkgdesc = Music library app for Mac, Linux and Windows
- pkgver = 0.17.1
- pkgrel = 5
+ pkgver = 0.17.2
+ pkgrel = 1
url = https://github.com/probablykasper/ferrum
arch = x86_64
- license = custom
- depends = electron19
+ license = LicenseRef-custom
+ depends = electron22
depends = hicolor-icon-theme
- provides = ferrum=0.17.1
+ provides = ferrum=0.17.2
conflicts = ferrum
- source = ferrum-0.17.1.deb::https://github.com/probablykasper/ferrum/releases/download/v0.17.1/Ferrum-v0.17.1-linux.deb
+ source = ferrum-0.17.2.deb::https://github.com/probablykasper/ferrum/releases/download/v0.17.2/Ferrum-v0.17.2-linux.deb
source = ferrum.sh
- sha256sums = 42a0c42c3d24d50ff90fc30a8036023c2721697f855b1a6b02209dfd8602807e
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 39822b21e5f8571b1fca614a8483b9d2c7cf985cc8b6f4c7a7a9a290de530292
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = ferrum-bin
diff --git a/PKGBUILD b/PKGBUILD
index f3f9a12e9f09..cc234713863a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=ferrum-bin
_pkgname=Ferrum
-pkgver=0.17.1
-_electronversion=19
-pkgrel=5
+pkgver=0.17.2
+_electronversion=22
+pkgrel=1
pkgdesc="Music library app for Mac, Linux and Windows"
arch=('x86_64')
url="https://github.com/probablykasper/ferrum"
-license=('custom')
+license=('LicenseRef-custom')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -18,8 +18,8 @@ source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}-v${pkgver}-linux.deb"
"${pkgname%-bin}.sh"
)
-sha256sums=('42a0c42c3d24d50ff90fc30a8036023c2721697f855b1a6b02209dfd8602807e'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+sha256sums=('39822b21e5f8571b1fca614a8483b9d2c7cf985cc8b6f4c7a7a9a290de530292'
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/ferrum.sh b/ferrum.sh
index c77c53567639..aacd8f895847 100644
--- a/ferrum.sh
+++ b/ferrum.sh
@@ -6,12 +6,10 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
- exit
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file