summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Grenier2017-01-12 09:57:59 +0100
committerBaptiste Grenier2017-01-12 10:02:39 +0100
commita42b1e46f8f48fd3264d977ed8867e6c656f8f9f (patch)
treeba98e577a37430ca6ef3fdda02e1f516706f8d84
downloadaur-a42b1e46f8f48fd3264d977ed8867e6c656f8f9f.tar.gz
PKGBUILD: first build of fetch-crl3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5d8f803fbd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fetch-crl3
+ pkgdesc = fetch-crl - the Certificate Revocation List retrieval tool
+ pkgver = 3.0.17
+ pkgrel = 1
+ url = https://dist.igtf.net/distribution/util/fetch-crl3/
+ arch = any
+ license = Apache
+ depends = perl
+ source = https://dist.eugridpma.info/distribution/util/fetch-crl3/fetch-crl-3.0.17.tar.gz
+ md5sums = 922e68915c1b30b266270759e0bcbe5d
+
+pkgname = fetch-crl3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad91d60bfb01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Baptiste Grenier <baptiste@bapt.name>
+pkgname=fetch-crl3
+pkgver=3.0.17
+pkgrel=1
+pkgdesc="fetch-crl - the Certificate Revocation List retrieval tool"
+arch=(any)
+url="https://dist.igtf.net/distribution/util/fetch-crl3/"
+license=('Apache')
+depends=('perl')
+source=(https://dist.eugridpma.info/distribution/util/$pkgname/fetch-crl-$pkgver.tar.gz)
+md5sums=('922e68915c1b30b266270759e0bcbe5d')
+
+package() {
+ cd "fetch-crl-$pkgver"
+ sed -i 's#/sbin#/bin#' Makefile
+ make PREFIX="$pkgdir/usr" ETC="$pkgdir/etc" CACHE="$pkgdir/var/cache" install
+ chmod +rx "$pkgdir/var/cache/fetch-crl"
+}