summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorling17292020-08-13 18:16:55 -0700
committerling17292020-08-13 18:16:55 -0700
commit40b3211c60368c8f2cfc9eac9200b80ab48c350e (patch)
treebec54d58fe6b691f1539ad04e5c0972901a6424c
downloadaur-40b3211c60368c8f2cfc9eac9200b80ab48c350e.tar.gz
Add PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..beb6bbe51eb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fetchcord-git
+ pkgdesc = FetchCord grabs your OS info and displays it as Discord Rich Presence
+ pkgver = 2.2
+ pkgrel = 1
+ url = https://github.com/MrPotatoBobx/fetchcord
+ arch = any
+ license = MIT
+ depends = python-pypresence
+ depends = neofetch
+ provides = fetchcord
+ source = fetchcord::git+https://github.com/MrPotatoBobx/fetchcord#branch=master
+ sha256sums = SKIP
+
+pkgname = fetchcord-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3ed2bbbe9561
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.zst
+fetchcord/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2bd765369e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer Lingfeng Ren <lastname+firstname+8thfibonaccinumber@gmail.com>
+
+pkgname=fetchcord-git
+pkgver=r261.c567d52
+pkgrel=1
+pkgdesc="FetchCord grabs your OS info and displays it as Discord Rich Presence"
+arch=('any')
+url="https://github.com/MrPotatoBobx/fetchcord"
+license=('MIT')
+depends=('python')
+provides=('fetchcord')
+depends=('python-pypresence' 'neofetch')
+source=("fetchcord::git+$url#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/fetchcord"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/fetchcord"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/fetchcord"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}