summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKévin Le Torc'h2021-06-29 22:14:49 +0200
committerKévin Le Torc'h2021-06-29 22:14:49 +0200
commit3365eb4521128eb131c4ae9a241da182b9fe0887 (patch)
tree415a03295ed6071fb22add98d932a3806d062964
downloadaur-3365eb4521128eb131c4ae9a241da182b9fe0887.tar.gz
Initial fetchcord testing aur commit
-rw-r--r--.SRCINFO18
-rwxr-xr-x.gitignore4
-rwxr-xr-xPKGBUILD42
-rwxr-xr-xfetchcord.install5
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..132a820ee453
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fetchcord-testing-git
+ pkgdesc = FetchCord grabs your OS info and displays it as Discord Rich Presence
+ pkgver = 7.7
+ pkgrel = 2
+ url = https://github.com/MrPotatoBobx/fetchcord
+ install = fetchcord.install
+ arch = any
+ license = MIT
+ depends = python-pypresence
+ depends = neofetch
+ depends = python-psutil
+ depends = python-setuptools
+ provides = fetchcord
+ source = fetchcord::git+https://github.com/MrPotatoBobx/fetchcord#branch=testing
+ sha256sums = SKIP
+
+pkgname = fetchcord-testing-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..3ed2bbbe9561
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.zst
+fetchcord/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..b868ac3151f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer BlivionIaG <kev29lt@gmail.com>
+
+pkgname=fetchcord-testing-git
+pkgver=7.7
+pkgrel=2
+pkgdesc="FetchCord grabs your OS info and displays it as Discord Rich Presence"
+arch=('any')
+url="https://github.com/MrPotatoBobx/fetchcord"
+license=('MIT')
+depends=('python')
+provides=('fetchcord')
+depends=('python-pypresence' 'neofetch' 'python-psutil' 'python-setuptools')
+source=("fetchcord::git+$url#branch=testing")
+sha256sums=('SKIP')
+install=fetchcord.install
+
+pkgver() {
+ cd "$srcdir/fetchcord"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/fetchcord"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/fetchcord"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ systemddir="/usr/lib/systemd/user"
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+
+ if [ -e "$systemddir/fetchcord.service" ]; then
+ echo "Not overwriting existing fetchcord.service" && install -Dm644 "$systemddir/fetchcord.service" "$pkgdir$systemddir/fetchcord.service";
+ else
+ install -Dm644 systemd/fetchcord.service "$pkgdir$systemddir/fetchcord.service";
+ fi
+
+}
diff --git a/fetchcord.install b/fetchcord.install
new file mode 100755
index 000000000000..7865afc1a559
--- /dev/null
+++ b/fetchcord.install
@@ -0,0 +1,5 @@
+post_install() {
+ cat << EOF
+==> To start the service on boot run systemctl --user enable --now fetchcord.service
+EOF
+}