aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManoel Brunnen2016-09-10 12:04:28 +0200
committerManoel Brunnen2016-09-10 12:04:28 +0200
commit5741fb8e3fd4b1f13195a376db8cb10b9a17fe4d (patch)
treeb1ab6902662efd1736a05b66142320f147713dc1
parent18311d8c58e81f2b0a21e4087d0c573da38f1c55 (diff)
downloadaur-5741fb8e3fd4b1f13195a376db8cb10b9a17fe4d.tar.gz
didn't push when nothing to commit
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xfetcher.sh3
3 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42caaa89a0fa..9bb37076f053 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fetcher
pkgdesc = Automatic adding, commiting, pushing or pulling of git repos via a systemd service unit.
pkgver = 1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mbrunnen/fetcher
install = fetcher.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 8fe676ea1c48..43994da70b2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=fetcher
pkgver=1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Automatic adding, commiting, pushing or pulling of git repos via a systemd service unit."
arch=('any')
url="https://github.com/mbrunnen/fetcher"
diff --git a/fetcher.sh b/fetcher.sh
index 01a5b724221f..1dca1ecab3fc 100755
--- a/fetcher.sh
+++ b/fetcher.sh
@@ -100,7 +100,8 @@ for ((i=0; i < ${#lines[@]}; i++)); do
if $dryrun; then
cmd="git -C $path add -n -A"
cmd="$cmd && git -C $path commit -n -v"
- cmd="$cmd && git -C $path push -n $remote $branch"
+ # Push nonetheles
+ cmd="$cmd; git -C $path push -n $remote $branch"
else
cmd="git -C $path add -A"
cmd="$cmd && git -C $path commit -v"