aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManoel Brunnen2016-09-08 07:57:00 +0200
committerManoel Brunnen2016-09-08 07:57:00 +0200
commitbe06996dbc29ae04308d86a204294610b0c5e868 (patch)
treef0e429c1cb7a282bfc41561f7c8031a21ff40039
parenta5c4bde879fd91c6f5caeca41bd9878c717aa11f (diff)
downloadaur-be06996dbc29ae04308d86a204294610b0c5e868.tar.gz
changed to systemd user service
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--fetcher.install5
-rw-r--r--fetcher.service7
4 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2eeb5c73721a..586904c3c713 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fetcher
pkgdesc = Automatic adding, commiting, pushing or pulling of git repos via a systemd service unit.
- pkgver = 1.0
- pkgrel = 1
+ pkgver = 1.1
+ pkgrel = 0
url = https://github.com/mbrunnen/fetcher
install = fetcher.install
arch = any
@@ -10,7 +10,7 @@ pkgbase = fetcher
source = fetcher.sh
source = fetcher.service
md5sums = 5df683b5b96f5e83331ab071b0979613
- md5sums = ac026457052512cfdb9ae12e100ea696
+ md5sums = dab6b2be6bfbd3f2b77b000814e1e9fd
pkgname = fetcher
diff --git a/PKGBUILD b/PKGBUILD
index 65e2c5db6df1..bdb32460ca30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Manoel Brunnen <manoel.brunnen@gmail.com>
pkgname=fetcher
-pkgver=1.0
-pkgrel=1
+pkgver=1.1
+pkgrel=0
pkgdesc="Automatic adding, commiting, pushing or pulling of git repos via a systemd service unit."
arch=('any')
url="https://github.com/mbrunnen/fetcher"
@@ -14,10 +14,10 @@ source=("fetcher.sh"
"fetcher.service")
noextract=()
md5sums=('5df683b5b96f5e83331ab071b0979613'
- 'ac026457052512cfdb9ae12e100ea696')
+ 'dab6b2be6bfbd3f2b77b000814e1e9fd')
package() {
- install -Dm644 $srcdir/fetcher.service $pkgdir/usr/lib/systemd/system/fetcher@$USER.service
+ install -Dm644 $srcdir/fetcher.service $pkgdir/usr/lib/systemd/user/fetcher.service
install -Dm755 $srcdir/fetcher.sh $pkgdir/usr/bin/fetcher
}
diff --git a/fetcher.install b/fetcher.install
index 0009b115d473..82bb3251b6d3 100644
--- a/fetcher.install
+++ b/fetcher.install
@@ -1,6 +1,9 @@
post_install() {
echo ================================== Important =================================
+ echo Start the fetcher daemon with:
+ echo systemctl start --user fetcher.service
+ echo ==============================================================================
echo Enable the fetcher daemon with:
- echo systemctl enable fetcher@\$USER.service
+ echo systemctl enable --user fetcher.service
echo ==============================================================================
}
diff --git a/fetcher.service b/fetcher.service
index 272a1afd2b17..7b49747f62c4 100644
--- a/fetcher.service
+++ b/fetcher.service
@@ -1,13 +1,10 @@
[Unit]
Description=Update some git repos
-Wants=network-online.target
After=network-online.target
[Service]
-Type=simple
-User=%i
-ExecStart=/bin/bash /usr/bin/fetcher -f=/home/%i/.config/fetcher.conf
+ExecStart=/bin/bash /usr/bin/fetcher -f=%h/.config/fetcher.conf
[Install]
-WantedBy=multi-user.target
+WantedBy=default.target
; vim:set ft=systemd: