summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2020-04-07 14:16:00 +0530
committerAmish2020-04-07 14:16:00 +0530
commit36163f9c377bd653174e896efe8dbd87b43feb27 (patch)
tree6fd2943a07933ef41c6fa695127a989124900d40
parente13a7dbbb79f9185502df58149c1e183ff7bc9f6 (diff)
downloadaur-36163f9c377bd653174e896efe8dbd87b43feb27.tar.gz
python2 to python
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ae93b51b2b6..284f0c00aacb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,10 +5,10 @@ pkgbase = fetchmail
url = http://www.fetchmail.info
arch = x86_64
license = GPL
- makedepends = python2
+ makedepends = python
depends = openssl
optdepends = tk: for using fetchmailconf
- optdepends = python2: for using fetchmailconf
+ optdepends = python-future: for using fetchmailconf
options = !makeflags
source = https://sourceforge.net/projects/fetchmail/files/branch_6.4/fetchmail-6.4.3.tar.xz
source = fetchmail.tmpfiles
diff --git a/PKGBUILD b/PKGBUILD
index ae4ad8aec9a9..b81236c91580 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,9 @@ arch=('x86_64')
url="http://www.fetchmail.info"
license=('GPL')
depends=('openssl')
-makedepends=('python2')
+makedepends=('python')
optdepends=('tk: for using fetchmailconf'
- 'python2: for using fetchmailconf')
+ 'python-future: for using fetchmailconf')
options=('!makeflags')
source=("https://sourceforge.net/projects/fetchmail/files/branch_${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
'fetchmail.tmpfiles' 'fetchmail.sysusers' 'fetchmail.service')
@@ -21,8 +21,7 @@ sha1sums=('14dbbad6714d3498920ed4058479a3ddf34fe96c'
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- sed -i 's|/usr/bin/env python|/usr/bin/env python2|' fetchmailconf.py
- PYTHON=python2 ./configure --prefix=/usr --with-ssl=/usr
+ ./configure --prefix=/usr --with-ssl=/usr
make
}