summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-04-03 06:19:49 +0000
committerAntonio Rojas2019-04-03 06:19:49 +0000
commitaae48e2dc50ee16aefc486d060b87cc1db006f77 (patch)
tree0cff32e0d45afc460ac532b7b6332d27624ba63e
downloadaur-aae48e2dc50ee16aefc486d060b87cc1db006f77.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD43
-rw-r--r--disable-sslv3.patch20
-rw-r--r--fetchmail.service11
-rw-r--r--fetchmail.sysusers2
-rw-r--r--fetchmail.tmpfiles1
6 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44eb6e70a494
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = fetchmail
+ pkgdesc = A remote-mail retrieval utility
+ pkgver = 6.3.26
+ pkgrel = 7
+ url = http://www.fetchmail.info
+ arch = x86_64
+ license = GPL
+ makedepends = python2
+ depends = openssl
+ optdepends = tk: for using fetchmailconf
+ optdepends = python2: for using fetchmailconf
+ options = !makeflags
+ source = https://sourceforge.net/projects/fetchmail/files/branch_6.3/fetchmail-6.3.26.tar.xz
+ source = https://sourceforge.net/projects/fetchmail/files/branch_6.3/fetchmail-6.3.26.tar.xz.asc
+ source = disable-sslv3.patch
+ source = fetchmail.tmpfiles
+ source = fetchmail.sysusers
+ source = fetchmail.service
+ validpgpkeys = FDD00C436E3307E10758C6A8BE618339052E7D95
+ sha1sums = de8dbe62a8edfa232ee4278257a1fe67aa1c797a
+ sha1sums = SKIP
+ sha1sums = dab3bf46b033e8ee7cadc020c1fb4ce325f46693
+ sha1sums = 199ba749c829f22286c34aabcf8b7dd5bbd7c0e6
+ sha1sums = b113cb61a866eff53cd8f113d084a99f01bf5d77
+ sha1sums = 0fc1870a33d1e0efb70169ddf1b6adc9d253e076
+
+pkgname = fetchmail
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d69a7745687a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+
+pkgname=fetchmail
+pkgver=6.3.26
+pkgrel=7
+pkgdesc="A remote-mail retrieval utility"
+arch=('x86_64')
+url="http://www.fetchmail.info"
+license=('GPL')
+depends=('openssl')
+makedepends=('python2')
+optdepends=('tk: for using fetchmailconf'
+ 'python2: for using fetchmailconf')
+options=('!makeflags')
+source=("https://sourceforge.net/projects/fetchmail/files/branch_6.3/${pkgname}-${pkgver}.tar.xz"{,.asc}
+ 'disable-sslv3.patch' 'fetchmail.tmpfiles' 'fetchmail.sysusers' 'fetchmail.service')
+sha1sums=('de8dbe62a8edfa232ee4278257a1fe67aa1c797a'
+ 'SKIP'
+ 'dab3bf46b033e8ee7cadc020c1fb4ce325f46693'
+ '199ba749c829f22286c34aabcf8b7dd5bbd7c0e6'
+ 'b113cb61a866eff53cd8f113d084a99f01bf5d77'
+ '0fc1870a33d1e0efb70169ddf1b6adc9d253e076')
+validpgpkeys=('FDD00C436E3307E10758C6A8BE618339052E7D95')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i ../disable-sslv3.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i 's|/usr/bin/env python|/usr/bin/env python2|' fetchmailconf.py
+ PYTHON=python2 ./configure --prefix=/usr --with-ssl=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -d -o 90 -g nobody "${pkgdir}/var/lib/fetchmail"
+ install -D -m644 ${srcdir}/fetchmail.tmpfiles ${pkgdir}/usr/lib/tmpfiles.d/fetchmail.conf
+ install -D -m644 ${srcdir}/fetchmail.sysusers ${pkgdir}/usr/lib/sysusers.d/fetchmail.conf
+ install -D -m644 ${srcdir}/fetchmail.service ${pkgdir}/usr/lib/systemd/system/fetchmail.service
+}
diff --git a/disable-sslv3.patch b/disable-sslv3.patch
new file mode 100644
index 000000000000..2edc41e2be37
--- /dev/null
+++ b/disable-sslv3.patch
@@ -0,0 +1,20 @@
+diff -u -r fetchmail-6.3.26/socket.c fetchmail-6.3.26-nossl3/socket.c
+--- fetchmail-6.3.26/socket.c 2013-04-23 22:00:45.000000000 +0200
++++ fetchmail-6.3.26-nossl3/socket.c 2016-03-03 18:18:46.688881618 +0100
+@@ -907,14 +907,11 @@
+ _ssl_context[sock] = NULL;
+ if(myproto) {
+ if(!strcasecmp("ssl2",myproto)) {
+-#if HAVE_DECL_SSLV2_CLIENT_METHOD + 0 > 0
+- _ctx[sock] = SSL_CTX_new(SSLv2_client_method());
+-#else
+ report(stderr, GT_("Your operating system does not support SSLv2.\n"));
+ return -1;
+-#endif
+ } else if(!strcasecmp("ssl3",myproto)) {
+- _ctx[sock] = SSL_CTX_new(SSLv3_client_method());
++ report(stderr, GT_("Your operating system does not support SSLv3.\n"));
++ return -1;
+ } else if(!strcasecmp("tls1",myproto)) {
+ _ctx[sock] = SSL_CTX_new(TLSv1_client_method());
+ } else if (!strcasecmp("ssl23",myproto)) {
diff --git a/fetchmail.service b/fetchmail.service
new file mode 100644
index 000000000000..64c118270de8
--- /dev/null
+++ b/fetchmail.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Fetchmail
+After=network.target
+
+[Service]
+User=fetchmail
+ExecStart=/usr/bin/fetchmail -d 900 -f /etc/fetchmailrc
+RestartSec=1
+
+[Install]
+WantedBy=multi-user.target
diff --git a/fetchmail.sysusers b/fetchmail.sysusers
new file mode 100644
index 000000000000..57f99eec7d64
--- /dev/null
+++ b/fetchmail.sysusers
@@ -0,0 +1,2 @@
+u fetchmail 90 "Fetchmail daemon" /var/lib/fetchmail
+m fetchmail nobody
diff --git a/fetchmail.tmpfiles b/fetchmail.tmpfiles
new file mode 100644
index 000000000000..07945f876468
--- /dev/null
+++ b/fetchmail.tmpfiles
@@ -0,0 +1 @@
+d /run/fetchmail 700 fetchmail nobody