summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2020-04-07 12:13:07 +0530
committerAmish2020-04-07 12:13:07 +0530
commite13a7dbbb79f9185502df58149c1e183ff7bc9f6 (patch)
tree0318843ac476bf97b39c42d534d33c2ce947358e
parent23700bebff48aa9e3dfa361434b5315358618d3e (diff)
downloadaur-e13a7dbbb79f9185502df58149c1e183ff7bc9f6.tar.gz
Update to 6.4.3
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
-rw-r--r--disable-sslv3.patch20
-rw-r--r--fetchmail.service2
-rw-r--r--fetchmail.sysusers2
-rw-r--r--fetchmail.tmpfiles1
7 files changed, 26 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 047112e49aca..6ae93b51b2b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fetchmail
pkgdesc = A remote-mail retrieval utility
- pkgver = 6.4.1
+ pkgver = 6.4.3
pkgrel = 1
url = http://www.fetchmail.info
arch = x86_64
@@ -10,14 +10,14 @@ pkgbase = fetchmail
optdepends = tk: for using fetchmailconf
optdepends = python2: for using fetchmailconf
options = !makeflags
- source = https://sourceforge.net/projects/fetchmail/files/branch_6.4/fetchmail-6.4.1.tar.xz
+ source = https://sourceforge.net/projects/fetchmail/files/branch_6.4/fetchmail-6.4.3.tar.xz
source = fetchmail.tmpfiles
source = fetchmail.sysusers
source = fetchmail.service
- sha1sums = 1aadf078ed8fb1b6c93e9126cc0375b1f740301a
- sha1sums = 199ba749c829f22286c34aabcf8b7dd5bbd7c0e6
- sha1sums = b113cb61a866eff53cd8f113d084a99f01bf5d77
- sha1sums = 0fc1870a33d1e0efb70169ddf1b6adc9d253e076
+ sha1sums = 14dbbad6714d3498920ed4058479a3ddf34fe96c
+ sha1sums = 227f1c6a4ea15d73d22d5db9330566e174c45cf9
+ sha1sums = 4d1f04cfa50b708736784cd6d3f4e8c1c624c680
+ sha1sums = 0d06feaaef5e837758da3100332f8fb15f02b5b1
pkgname = fetchmail
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b8cd6fd61754
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*x86_64.pkg.tar.xz
+fetchmail-*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 2f3f2faa5e2f..ae4ad8aec9a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Victor3D <webmaster@victor3d.com.br>
+# Maintainer: Amish <contact at via dot aur>
+# Contributor: Victor3D <webmaster@victor3d.com.br>
pkgname=fetchmail
-pkgver=6.4.1
-_majver=6.4
+pkgver=6.4.3
pkgrel=1
pkgdesc="A remote-mail retrieval utility"
arch=('x86_64')
@@ -12,12 +12,12 @@ makedepends=('python2')
optdepends=('tk: for using fetchmailconf'
'python2: for using fetchmailconf')
options=('!makeflags')
-source=("https://sourceforge.net/projects/fetchmail/files/branch_${_majver}/${pkgname}-${pkgver}.tar.xz"
- 'fetchmail.tmpfiles' 'fetchmail.sysusers' 'fetchmail.service')
-sha1sums=('1aadf078ed8fb1b6c93e9126cc0375b1f740301a'
- '199ba749c829f22286c34aabcf8b7dd5bbd7c0e6'
- 'b113cb61a866eff53cd8f113d084a99f01bf5d77'
- '0fc1870a33d1e0efb70169ddf1b6adc9d253e076')
+source=("https://sourceforge.net/projects/fetchmail/files/branch_${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
+ 'fetchmail.tmpfiles' 'fetchmail.sysusers' 'fetchmail.service')
+sha1sums=('14dbbad6714d3498920ed4058479a3ddf34fe96c'
+ '227f1c6a4ea15d73d22d5db9330566e174c45cf9'
+ '4d1f04cfa50b708736784cd6d3f4e8c1c624c680'
+ '0d06feaaef5e837758da3100332f8fb15f02b5b1')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -29,9 +29,8 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- install -d -o 90 -g nobody "${pkgdir}/var/lib/fetchmail"
- cd -
- install -D -m644 fetchmail.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/fetchmail.conf
- install -D -m644 fetchmail.sysusers "$pkgdir"/usr/lib/sysusers.d/fetchmail.conf
- install -D -m644 fetchmail.service "$pkgdir"/usr/lib/systemd/system/fetchmail.service
+ cd "${srcdir}"
+ install -D -m644 fetchmail.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/fetchmail.conf
+ install -D -m644 fetchmail.sysusers "${pkgdir}"/usr/lib/sysusers.d/fetchmail.conf
+ install -D -m644 fetchmail.service "${pkgdir}"/usr/lib/systemd/system/fetchmail.service
}
diff --git a/disable-sslv3.patch b/disable-sslv3.patch
deleted file mode 100644
index 2edc41e2be37..000000000000
--- a/disable-sslv3.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -u -r fetchmail-6.3.26/socket.c fetchmail-6.3.26-nossl3/socket.c
---- fetchmail-6.3.26/socket.c 2013-04-23 22:00:45.000000000 +0200
-+++ fetchmail-6.3.26-nossl3/socket.c 2016-03-03 18:18:46.688881618 +0100
-@@ -907,14 +907,11 @@
- _ssl_context[sock] = NULL;
- if(myproto) {
- if(!strcasecmp("ssl2",myproto)) {
--#if HAVE_DECL_SSLV2_CLIENT_METHOD + 0 > 0
-- _ctx[sock] = SSL_CTX_new(SSLv2_client_method());
--#else
- report(stderr, GT_("Your operating system does not support SSLv2.\n"));
- return -1;
--#endif
- } else if(!strcasecmp("ssl3",myproto)) {
-- _ctx[sock] = SSL_CTX_new(SSLv3_client_method());
-+ report(stderr, GT_("Your operating system does not support SSLv3.\n"));
-+ return -1;
- } else if(!strcasecmp("tls1",myproto)) {
- _ctx[sock] = SSL_CTX_new(TLSv1_client_method());
- } else if (!strcasecmp("ssl23",myproto)) {
diff --git a/fetchmail.service b/fetchmail.service
index 64c118270de8..ae502b728af1 100644
--- a/fetchmail.service
+++ b/fetchmail.service
@@ -4,7 +4,7 @@ After=network.target
[Service]
User=fetchmail
-ExecStart=/usr/bin/fetchmail -d 900 -f /etc/fetchmailrc
+ExecStart=/usr/bin/fetchmail -f /etc/fetchmailrc
RestartSec=1
[Install]
diff --git a/fetchmail.sysusers b/fetchmail.sysusers
index 57f99eec7d64..167ed6fdfe9f 100644
--- a/fetchmail.sysusers
+++ b/fetchmail.sysusers
@@ -1,2 +1,2 @@
-u fetchmail 90 "Fetchmail daemon" /var/lib/fetchmail
+u fetchmail - "Fetchmail daemon" /var/lib/fetchmail
m fetchmail nobody
diff --git a/fetchmail.tmpfiles b/fetchmail.tmpfiles
index 07945f876468..458ac22489b6 100644
--- a/fetchmail.tmpfiles
+++ b/fetchmail.tmpfiles
@@ -1 +1,2 @@
d /run/fetchmail 700 fetchmail nobody
+d /var/lib/fetchmail 755 fetchmail nobody