summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordeadhead4202017-03-18 21:08:23 -0400
committerdeadhead4202017-03-18 21:08:23 -0400
commitd57630dfbc32b201ffa946466db839dcf4e5a627 (patch)
tree3588ac57331607e040257c853fe2bdd3d29887fc
downloadaur-d57630dfbc32b201ffa946466db839dcf4e5a627.tar.gz
Fetchpkg first commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48e3376be1c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = fetchpkg
+ pkgdesc = CLI frontend for pacman / AUR
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/deadhead420/fetchpkg
+ arch = any
+ license = GPL
+ depends = curl
+ source = https://github.com/deadhead420/fetchpkg.git
+
+pkgname = fetchpkg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9e815f50c0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: deadhead <deadhead3492@gmail.com>
+pkgname=fetchpkg
+pkgver=0.1
+pkgrel=1
+pkgdesc="CLI frontend for pacman / AUR"
+arch=('any')
+url="https://github.com/deadhead420/fetchpkg"
+license=('GPL')
+depends=('curl')
+optdepends=('fetchmirrors: update and rank pacman mirrorlist')
+source=(git+https://github.com/deadhead420/fetchpkg.git)
+md5sums=('SKIP')
+
+package() {
+ cd "${srcdir}"/fetchpkg
+ install -Dm755 fetchpkg "$pkgdir"/usr/bin/fetchpkg
+ install -Dm644 fetchpkg.conf "$pkgdir"/etc/fetchpkg.conf
+}
+
+# vim:set ts=2 sw=2 et: