summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0k3r2014-02-07 20:01:46 +0100
committerJ0k3r2014-02-07 20:58:56 +0100
commit3fc6ff8b08eecb42e86359118d3464e9fd14ad9e (patch)
tree75c4a36eec3fd651eb3f81f200f21864c9df4055
downloadaur-3fc6ff8b08eecb42e86359118d3464e9fd14ad9e.tar.gz
AUR4 split: Initial Commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD89
-rw-r--r--fez.changelog31
-rw-r--r--fez.desktop11
5 files changed, 163 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b4998d97e09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = fez
+ pkgdesc = A game where you play as Gomez, a 2D creature living in what he believes is a 2D world
+ pkgver = 20130915
+ pkgrel = 1
+ epoch = 1
+ url = http://fezgame.com/
+ changelog = fez.changelog
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = unknown
+ makedepends = unzip
+ makedepends = imagemagick
+ depends = gcc-libs
+ depends = bash
+ depends = sdl2
+ depends = openal
+ noextract = fez-09152013-bin
+ source = hib://fez-09152013-bin
+ source = fez.desktop
+ source = fez.changelog
+ sha256sums = 91b56f8bd558dba4cdc8d070a66c6c15071533d7456d2f1629a14b3af55c5e6e
+ sha256sums = 7d28fe54e85ab3b9d33337a745a412bdab8fa233b40f8137475dc142f434bbcf
+ sha256sums = 6e3bb1dca64e050a09bb2ab87f3f2a5cc42e419a46ffbea2abfc06502ca3173f
+
+pkgname = fez
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8c4ae8b06b82
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.pkg.*
+*.src.*
+fez-*-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34b75c58b8ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,89 @@
+# Maintainer: J0k3r <moebius282 e4at gmail D0_T com>
+
+pkgname=fez
+_datever="09152013"
+# _binver="1379017964"
+pkgver="20130915"
+pkgrel=1
+epoch=1
+pkgdesc="A game where you play as Gomez, a 2D creature living in what he believes is a 2D world"
+url="http://fezgame.com/"
+license=('unknown')
+arch=('i686' 'x86_64')
+groups=("games")
+depends=('gcc-libs' 'bash' 'sdl2' 'openal')
+makedepends=('unzip' 'imagemagick')
+changelog="${pkgname}.changelog"
+_purgelibs=('libopenal.so.1' 'libSDL2-2.0.so.0')
+# _archivename="fez-${_datever}-${_binver}-bin"
+_archivename="fez-${_datever}-bin"
+source=("hib://${_archivename}"
+ "${pkgname}.desktop"
+ "${pkgname}.changelog")
+noextract=("${_archivename}")
+sha256sums=('91b56f8bd558dba4cdc8d070a66c6c15071533d7456d2f1629a14b3af55c5e6e'
+ '7d28fe54e85ab3b9d33337a745a412bdab8fa233b40f8137475dc142f434bbcf'
+ '6e3bb1dca64e050a09bb2ab87f3f2a5cc42e419a46ffbea2abfc06502ca3173f')
+PKGEXT=".pkg.tar"
+
+
+
+# You can download the Humble Indie Bundle file manually, or you can configure
+# DLAGENTS in makepkg.conf to auto-download.
+#
+# For example, to use hib-dlagent to download files set something like this in
+# your makepkg.conf (change/add -k and add -u/-p to your needs):
+# DLAGENTS=('hib::/usr/bin/hib-dlagent -k 1a2b3c -o %o $(echo %u | cut -c 7-)')
+#
+# To auto-search through a directory containing Humble Bundle downloads, you
+# could set:
+# DLAGENTS=('hib::/usr/bin/find /path/to/downloads -name $(echo %u | cut -c 7-) -exec ln -s \{\} %o \; -quit')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+
+package()
+{
+ mkdir -p "${pkgdir}/opt/${pkgname}/"
+
+# unzip is stupid..
+ unzip -qq "${srcdir}/${_archivename}" -d "${pkgdir}/opt/tmp/" 'data/*' || true
+
+ mv "${pkgdir}/opt/tmp/data/"* "${pkgdir}/opt/${pkgname}/"
+ rm -r "${pkgdir}/opt/tmp/"
+
+
+ if [[ "$CARCH" == "x86_64" ]]; then
+
+ rm -r "${pkgdir}/opt/${pkgname}/lib/"
+ rm "${pkgdir}/opt/${pkgname}/${pkgname^^}.bin.x86"
+ for i in "${_purgelibs[@]}"; do
+ rm "${pkgdir}/opt/${pkgname}/lib64/${i}"
+ done
+
+ else
+
+ rm -r "${pkgdir}/opt/${pkgname}/lib64/"
+ rm "${pkgdir}/opt/${pkgname}/${pkgname^^}.bin.x86_64"
+ for i in "${_purgelibs[@]}"; do
+ rm "${pkgdir}/opt/${pkgname}/lib/${i}"
+ done
+
+ fi
+
+# patching the included startup script so it supports being symlinked
+# removing the steam bits out of the lib search path; i don't know why it contains a steam dir in the non-steam version..
+ sed -i \
+ -e 's|`dirname "$0"`|$(dirname \"$(readlink -f \"$0\")\")|' \
+ "${pkgdir}/opt/${pkgname}/${pkgname^^}"
+
+ mkdir -p "${pkgdir}/usr/bin/"
+ ln -s "/opt/${pkgname}/${pkgname^^}" "${pkgdir}/usr/bin/${pkgname}"
+
+# the spec only specifies png, svg and xpm..
+
+ convert "${pkgdir}/opt/${pkgname}/${pkgname^^}.bmp" "${pkgdir}/opt/${pkgname}/${pkgname}.png"
+
+
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "${pkgdir}/opt/${pkgname}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+} \ No newline at end of file
diff --git a/fez.changelog b/fez.changelog
new file mode 100644
index 000000000000..35e10d3b7534
--- /dev/null
+++ b/fez.changelog
@@ -0,0 +1,31 @@
+2013-09-11 | J0k3r <moebius282 e4at gmail D0_T com>
+
+ * fez-1378846930-1:
+ - Inital Release ( fez-09102013-linux-1378846930-bin )
+
+2013-09-12 | J0k3r <moebius282 e4at gmail D0_T com>
+
+ * fez-1378846930-2:
+ - Added Changelog
+
+ - Removed the bundled openal and sdl2 libs. Can't remove the bundled mono,
+ as the version in the repos is too old ( for monogame-sdl2 i guess).
+
+ * fez-20130911-1:
+ - Updated to latest release ( fez-09112013-bin )
+
+ - Changed to new versioning scheme; set epoch. geez..
+
+2013-09-13 | J0k3r <moebius282 e4at gmail D0_T com>
+
+ * fez-20130912-1
+ - Updated to latest release ( fez-09122013-1379017964-bin )
+
+ - Kept the date-based versioning, let's see if this will cause any troubles in the future..
+ ( I guess it's too hard to name the archives consistently!? )
+
+2013-09-16 | J0k3r <moebius282 e4at gmail D0_T com>
+
+ * fez-20130915-1
+ - Updated to latest release ( fez-09152013-bin )
+
diff --git a/fez.desktop b/fez.desktop
new file mode 100644
index 000000000000..ecdf5d2e270d
--- /dev/null
+++ b/fez.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Fez
+Comment=A game where you play as Gomez, a 2D creature living in what he believes is a 2D world
+Icon=fez.png
+Exec=fez
+Categories=Game;
+Path=/opt/fez
+