summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordax2018-12-15 00:01:48 -0600
committerdax2018-12-15 00:01:48 -0600
commit6689908770d7d549b8c632c7ecaf347ddc165294 (patch)
tree13547f223d3edc2acdebda0ef2cc6fbe27a274cc
downloadaur-6689908770d7d549b8c632c7ecaf347ddc165294.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..322cf3d5ad69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ff
+ pkgdesc = Simple, human-readable, fast binary file scanner
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://git.dd86k.space/dd86k/ff
+ arch = x86_64
+ license = MIT
+ makedepends = clang
+ source = https://git.dd86k.space/dd86k/ff/archive/v0.4.0.tar.gz
+ sha256sums = ae39a976623863903f0daeefffb444c0323f93f7021c9a426ee8b73481fdc2a1
+
+pkgname = ff
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e3034d3d701
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: dax <dev@dax.moe>
+pkgname=ff
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Simple, human-readable, fast binary file scanner"
+arch=('x86_64')
+url="https://git.dd86k.space/dd86k/ff"
+license=('MIT')
+depends=()
+makedepends=('clang')
+source=("https://git.dd86k.space/dd86k/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('ae39a976623863903f0daeefffb444c0323f93f7021c9a426ee8b73481fdc2a1')
+build() {
+ cd "$pkgname-v$pkgver"
+ sh ./build-clang.sh
+}
+
+package() {
+ cd "$pkgname-v$pkgver"
+ install -D ff "$pkgdir"/usr/bin/ff
+ install -D -m 0644 LICENSE "$pkgdir"/usr/share/licenses/ff/LICENSE
+ install -D -m 0644 README.md "$pkgdir"/usr/share/doc/ff/README.md
+ install -D -m 0644 docs/ff.1 "$pkgdir"/usr/share/man/man1/ff.1
+}