summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLamelos2018-11-07 12:27:31 +0100
committerThomas Rijpstra2018-11-07 12:27:39 +0100
commitab224805bab94ddc6223aa5a8ce95d74a33e781a (patch)
tree79cb1c0cbf7be8ad446b2dd5853e18bab655ca50
downloadaur-ab224805bab94ddc6223aa5a8ce95d74a33e781a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
-rw-r--r--ff2mpv.install4
-rw-r--r--point-ff2mpv-config-to-python-location.patch12
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2050a92f1f30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ff2mpv-native-messaging-host-git
+ pkgdesc = Native Messaging Host for ff2mpv firefox addon.
+ pkgver = r10.c66cc85
+ pkgrel = 1
+ url = https://github.com/woodruffw/ff2mpv
+ install = ff2mpv.install
+ arch = any
+ license = MIT
+ depends = python
+ depends = mpv
+ source = ff2mpv::git://github.com/woodruffw/ff2mpv.git
+ source = point-ff2mpv-config-to-python-location.patch
+ sha256sums = SKIP
+ sha256sums = 781abb58bf62138ad603bc67e3227fb8d421091daf9e7475c45d971730b34090
+
+pkgname = ff2mpv-native-messaging-host-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15a0a6a82103
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Lamelos <lamelos plus aur at gmail dot com>
+
+_shortpkgname=ff2mpv
+_pkgname=$_shortpkgname-native-messaging-host
+pkgname=$_pkgname-git
+pkgver=r10.c66cc85
+pkgrel=1
+pkgdesc='Native Messaging Host for ff2mpv firefox addon.'
+license=('MIT')
+url='https://github.com/woodruffw/ff2mpv'
+arch=('any')
+depends=('python' 'mpv')
+install=$_shortpkgname.install
+source=("$_shortpkgname"::"git://github.com/woodruffw/ff2mpv.git"
+ "point-ff2mpv-config-to-python-location.patch")
+sha256sums=('SKIP'
+ '781abb58bf62138ad603bc67e3227fb8d421091daf9e7475c45d971730b34090')
+
+pkgver() {
+ cd "$srcdir/$_shortpkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir"
+ patch -Np1 -i point-ff2mpv-config-to-python-location.patch
+}
+
+package() {
+ cd "$srcdir/$_shortpkgname"
+ install -Dm655 "ff2mpv.py" "$pkgdir/usr/share/ff2mpv/ff2mpv.py"
+ install -Dm644 "ff2mpv.json" "$pkgdir/usr/lib/mozilla/native-messaging-hosts/ff2mpv.json"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/ff2mpv.install b/ff2mpv.install
new file mode 100644
index 000000000000..ba6ac7624a06
--- /dev/null
+++ b/ff2mpv.install
@@ -0,0 +1,4 @@
+post_install() {
+ printf "\nYou can install the addon from: https://addons.mozilla.org/en-US/firefox/addon/ff2mpv/\n"
+ printf "\n"
+}
diff --git a/point-ff2mpv-config-to-python-location.patch b/point-ff2mpv-config-to-python-location.patch
new file mode 100644
index 000000000000..b817d3de5c74
--- /dev/null
+++ b/point-ff2mpv-config-to-python-location.patch
@@ -0,0 +1,12 @@
+diff -ura package.orig/ff2mpv/ff2mpv.json package.new/ff2mpv/ff2mpv.json
+--- package.orig/ff2mpv/ff2mpv.json 2018-11-07 12:19:09.040290072 +0100
++++ package.new/ff2mpv/ff2mpv.json 2018-11-07 12:20:00.107211984 +0100
+@@ -1,7 +1,7 @@
+ {
+ "name": "ff2mpv",
+ "description": "ff2mpv's external manifest",
+- "path": "/home/william/scripts/ff2mpv",
++ "path": "/usr/share/ff2mpv/ff2mpv.py",
+ "type": "stdio",
+ "allowed_extensions": ["ff2mpv@yossarian.net"]
+ }