summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomek Łaziuk2018-02-17 12:58:06 +0100
committerTomek Łaziuk2018-02-17 12:58:06 +0100
commit945c07dd0e8b8e988572a1fdd93d4063addf49fd (patch)
tree9316c92b12eda22db9747a51910deaa787473ea1
downloadaur-945c07dd0e8b8e988572a1fdd93d4063addf49fd.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8fd9eeba8530
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ffautocrop-git
+ pkgdesc = automatically crop a video using ffmpeg
+ pkgver = 0.0.1.r0.g94c632c
+ pkgrel = 1
+ url = https://github.com/tlaziuk/ffautocrop
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = ffmpeg
+ provides = ffautocrop
+ conflicts = ffautocrop
+ source = git+https://github.com/tlaziuk/ffautocrop.git
+ md5sums = SKIP
+
+pkgname = ffautocrop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d65c250b8d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Tomek Łaziuk <tlaziuk@gmail.com>
+
+_pkgname=ffautocrop
+pkgname=$_pkgname-git
+pkgver=0.0.1.r0.g94c632c
+pkgrel=1
+pkgdesc="automatically crop a video using ffmpeg"
+arch=("any")
+url="https://github.com/tlaziuk/${_pkgname}"
+license=('GPL')
+depends=('ffmpeg')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/tlaziuk/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/${_pkgname}"
+}