summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chausse2020-02-18 21:32:06 -0500
committerBenjamin Chausse2020-02-18 21:32:06 -0500
commit982bed8f745b5690125e03a2e5b64d66b11c8788 (patch)
tree106180b84194445aa2b211aaacbf1683885be235
downloadaur-982bed8f745b5690125e03a2e5b64d66b11c8788.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f4c53be9814
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = fff-ueberzug-git
+ pkgdesc = A simple file manager written in bash. This fork uses ueberzug instead of w3m-img
+ pkgver = aaff747
+ pkgrel = 1
+ url = https://github.com/zeljkobekcic/fff
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = xdg-utils
+ depends = fbset
+ depends = python-ueberzug
+ depends = xdotool
+ provides = fff
+ conflicts = fff
+ conflicts = python-ueberzug-git
+ source = git+https://github.com/zeljkobekcic/fff.git
+ sha256sums = SKIP
+
+pkgname = fff-ueberzug-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf0e44deb1de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Benjamin Chausse <benjamin@chausse.xyz>
+
+pkgname=fff-ueberzug-git
+pkgver=aaff747
+pkgrel=1
+pkgdesc="A simple file manager written in bash. This fork uses ueberzug instead of w3m-img"
+arch=('any')
+url="https://github.com/zeljkobekcic/fff"
+license=('MIT')
+depends=(
+ 'xdg-utils'
+ 'fbset'
+ 'python-ueberzug'
+ 'xdotool'
+)
+makedepends=('git')
+optdepends=()
+provides=('fff')
+conflicts=(
+ 'fff'
+ 'python-ueberzug-git'
+)
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/fff"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/fff"
+ install -Dm755 fff "$pkgdir/usr/bin/fff"
+ install -Dm644 fff.1 "$pkgdir/usr/share/man/man1/fff.1"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}