summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2025-04-13 13:18:42 +0200
committergit user2025-04-13 13:18:42 +0200
commitb94baac594da8b45e86819990a2dd4eecb2e9920 (patch)
tree85e1c98b664a48a9bb887ab76b4e57fc0e979e32
parentff1a2d9d5cd11186e683411eaa63e7478575dfe9 (diff)
downloadaur-b94baac594da8b45e86819990a2dd4eecb2e9920.tar.gz
Now getting the version from 'git describe tags' and not from python module import. Upstream version update: 1.12.9.r615.20250402.4c28a27.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f56d4145b74..06f8505c3569 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffgo-git
pkgdesc = A graphical launcher for FlightGear, i.e., a program whose purpose is to allow easy assembling and running of an fgfs command line. (Fork of and replacement for 'FGo!'.)
- pkgver = 1.12.8.r607.20250328.1690fb6
+ pkgver = 1.12.9.r615.20250402.4c28a27
pkgrel = 1
url = http://frougon.net/projects/FFGo/
arch = any
@@ -20,7 +20,7 @@ pkgbase = ffgo-git
depends = python-pillow
depends = tk>=8.5
optdepends = geographiclib: For 'MagneticField' executable. (Seems not to work out of the box, though!)
- provides = ffgo=1.12.8.r607.20250328.1690fb6
+ provides = ffgo=1.12.9.r615.20250402.4c28a27
conflicts = ffgo
source = ffgo::git+https://github.com/frougon/FFGo.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index abd737d36552..6613f520b5fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=ffgo
pkgname="${_pkgname}-git"
-pkgver=1.12.8.r607.20250328.1690fb6
+pkgver=1.12.9.r615.20250402.4c28a27
pkgrel=1
pkgdesc="A graphical launcher for FlightGear, i.e., a program whose purpose is to allow easy assembling and running of an fgfs command line. (Fork of and replacement for 'FGo!'.)"
arch=('any')
@@ -61,9 +61,10 @@ pkgver() {
_date="$(git log -1 --format=%cd --date=format:%Y%m%d)"
_hash="$(git rev-parse --short HEAD)"
- cd ffgo
-
- _ver="$(python -c 'import version; print(version.__version__)')"
+ #cd src/ffgo
+ #
+ # _ver="$(python -c 'import version; print(version.__version__)')"
+ _ver="$(git describe --tags | sed -E -e 's|^[vV]||' -e 's|\-g[0-9a-f]*$||' | tr '-' '+')"
if [ -z ${_ver} ]; then
error "Could not determine version."