summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroot2021-04-17 00:41:13 +0200
committerroot2021-04-17 00:41:13 +0200
commitdd9b426b48b6433eeb90c6b47f59a3a3d932fa13 (patch)
treed3e3584a9220d02184393daf28a82096fbf45782
downloadaur-dd9b426b48b6433eeb90c6b47f59a3a3d932fa13.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD71
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca063877ba8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ffgo-git
+ pkgdesc = A graphical launcher for FlightGear, i.e., a program whose purpose is to allow easy assembling and running of an fgfs command line. (Fork of and replacement for 'FGo!'.)
+ pkgver = 1.12.7+r593.20200602.ee50e77
+ pkgrel = 1
+ url = http://frougon.net/projects/FFGo/
+ arch = any
+ license = custom
+ depends = python>=3.4
+ depends = python-condconfigparser
+ depends = tk>=8.5
+ optdepends = geographiclib
+ optdepends = python-geographiclib
+ optdepends = python-pillow
+ provides = ffgo=1.12.7+r593.20200602.ee50e77
+ conflicts = ffgo
+ source = ffgo::git+git://github.com/frougon/FFGo.git
+ sha256sums = SKIP
+
+pkgname = ffgo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6c3dc4a3c5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: dreieck
+# Contributer: Brian "Beej" Hall <beej@beej.us>
+# Contributer: Raphael Dümig <raphael[AT]duemig-neufahrn[DOT]de>
+
+_pkgname=ffgo
+pkgname="${_pkgname}-git"
+pkgver=1.12.7+r593.20200602.ee50e77
+pkgrel=1
+pkgdesc="A graphical launcher for FlightGear, i.e., a program whose purpose is to allow easy assembling and running of an fgfs command line. (Fork of and replacement for 'FGo!'.)"
+arch=('any')
+url="http://frougon.net/projects/FFGo/"
+# Git repository: https://github.com/frougon/FFGo
+license=('custom')
+depends=(
+ 'python>=3.4'
+ 'python-condconfigparser'
+ 'tk>=8.5'
+)
+makedepends=()
+optdepends=(
+ "geographiclib"
+ "python-geographiclib"
+ "python-pillow"
+)
+provides=(
+ "${_pkgname}=${pkgver}"
+)
+conflicts=(
+ "${_pkgname}"
+)
+source=(
+ "${_pkgname}::git+git://github.com/frougon/FFGo.git"
+)
+sha256sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ _rev="$(git rev-list HEAD --count)"
+ _date="$(git log -1 --format=%cd --date=format:%Y%m%d)"
+ _hash="$(git rev-parse --short HEAD)"
+ cd ffgo
+ _ver="$(python -c 'import version; print(version.__version__)')"
+ if [ -z ${_ver} ]; then
+ error "Could not determine version."
+ exit 1
+ else
+ printf '%s' "${_ver}+r${_rev}.${_date}.${_hash}"
+ fi
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ printf '%s\n' "${url}" > "upstream.url"
+
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ for _docfile in upstream.url ChangeLog ChangeLog.FGo README.rst; do
+ install -D -v -m644 "${_docfile}" "${pkgdir}/usr/share/doc/${_pkgname}/${_docfile}"
+ done
+
+ install -D -v -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ ln -svr "${pkgdir}/usr/share/licenses/${pkgname}/COPYING" "${pkgdir}/usr/share/doc/${_pkgname}/COPYING"
+}