summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Hauser2016-04-26 22:37:14 +0200
committerAndreas Hauser2016-04-26 22:37:14 +0200
commitf5a0449ef4092402fe392d5b64ce43d95c8df320 (patch)
tree46484fc7a4aaaba2c6394ed6fb504cf45887b951
parentea237f69d7e6b0c58662cbf14e20756c0c723112 (diff)
downloadaur-f5a0449ef4092402fe392d5b64ce43d95c8df320.tar.gz
Make with openmpi
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7baaccd5036e..7a603c362f67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Mon Mar 21 13:28:32 UTC 2016
+# Tue Apr 26 20:36:51 UTC 2016
pkgbase = ffindex
pkgdesc = simple index/database for huge amounts of small files
pkgver = 0.9.9.7
- pkgrel = 1
+ pkgrel = 2
url = http://www.splashground.de/~andy/programs/FFindex
arch = x86_64
arch = i686
license = CCPL:cc-by-sa-3.0
+ depends = openmpi
source = http://www.splashground.de/~andy/programs/FFindex/ffindex-0.9.9.7.tar.gz
sha256sums = c4c6e6be9eaf352fed795635f09df55da0a5c00dfa6ca2e463690bee3504ca03
diff --git a/PKGBUILD b/PKGBUILD
index c1a6381e597b..f3bdaa360aa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,23 @@
pkgbase=ffindex
pkgdesc="simple index/database for huge amounts of small files"
pkgver=0.9.9.7
-pkgrel=1
+pkgrel=2
url=http://www.splashground.de/~andy/programs/FFindex
arch=(x86_64 i686)
license=('CCPL:cc-by-sa-3.0')
source=("http://www.splashground.de/~andy/programs/FFindex/ffindex-${pkgver}.tar.gz")
sha256sums=('c4c6e6be9eaf352fed795635f09df55da0a5c00dfa6ca2e463690bee3504ca03')
pkgname=ffindex
+depends=(openmpi)
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- make
+ make HAVE_MPI=1
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
- make INSTALL_DIR=${pkgdir}/usr install
+ make INSTALL_DIR=${pkgdir}/usr install HAVE_MPI=1
mv ${pkgdir}/usr/lib64 ${pkgdir}/usr/lib
}