summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthurdw2022-08-14 14:52:18 +0200
committerArthurdw2022-08-14 14:52:18 +0200
commit5e0cdd91fbdb01e39cb42b79d5eb8b340850ecfb (patch)
tree47e8b0c92da52835e58358d27dfa33d8f347ab88
parent3c60058519e1ff3a82a103ea55aeae7786aab243 (diff)
downloadaur-5e0cdd91fbdb01e39cb42b79d5eb8b340850ecfb.tar.gz
:bookmark: New release
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 627f0fdc6cda..66cea730767d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Arthurdw <contact@arthurdw.com>
_name=ffly
+_loc="firefly/server"
pkgname=${_name}
-pkgver=0.0.0
+pkgver=0.0.1
pkgrel=1
pkgdesc="An \"blazingly\" fast key-value pair database without bloat written in rust"
arch=(x86_64 i686)
@@ -12,13 +13,13 @@ source=("git+https://github.com/Arthurdw/firefly.git")
sha256sums=('SKIP')
prepare() {
- cd "firefly/server"
+ cd $loc
cargo fetch --target "$CARCH-unknown-linux-gnu"
}
build() {
- cd "firefly/server"
+ cd $loc
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
@@ -27,15 +28,16 @@ build() {
package() {
- cd "firefly/server"
+ cd $loc
install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
}
check() {
- cd "firefly/server"
+ cd $loc
export RUSTUP_TOOLCHAIN=stable
cargo test --frozen --all-features
}
+