summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthurdw2022-08-14 15:09:51 +0200
committerArthurdw2022-08-14 15:09:51 +0200
commitd00b94628ce63f497731e9027c795d3c3400a490 (patch)
treecb6101d2cb39800c17107147f36a53174baf7452
parentca56eab8e2c5fa4ba0177976d55d77478682fd9f (diff)
downloadaur-d00b94628ce63f497731e9027c795d3c3400a490.tar.gz
:bookmark: Prepare bugfix
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD10
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3967a14f82f5..e620e2e9fa27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = ffly
-pkgdesc = A "blazingly" fast key-value pair database without bloat written in rust.
-pkgver = 0.0.1
-pkgrel = 1
-url = https://github.com/Arthurdw/firefly
-arch = x86_64
-arch = i686
-license = MIT
-makedepends = cargo
-source = git+https://github.com/Arthurdw/firefly.git
-sha256sums = SKIP
+ pkgdesc = An "blazingly" fast key-value pair database without bloat written in rust
+ pkgver = 0.0.1
+ pkgrel = 2
+ url = https://github.com/Arthurdw/firefly
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = cargo
+ source = git+https://github.com/Arthurdw/firefly.git
+ sha256sums = SKIP
pkgname = ffly
diff --git a/PKGBUILD b/PKGBUILD
index 66cea730767d..05534dd02451 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _name=ffly
_loc="firefly/server"
pkgname=${_name}
pkgver=0.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="An \"blazingly\" fast key-value pair database without bloat written in rust"
arch=(x86_64 i686)
url="https://github.com/Arthurdw/firefly"
@@ -13,13 +13,13 @@ source=("git+https://github.com/Arthurdw/firefly.git")
sha256sums=('SKIP')
prepare() {
- cd $loc
+ cd $_loc
cargo fetch --target "$CARCH-unknown-linux-gnu"
}
build() {
- cd $loc
+ cd $_loc
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
@@ -28,12 +28,12 @@ build() {
package() {
- cd $loc
+ cd $_loc
install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
}
check() {
- cd $loc
+ cd $_loc
export RUSTUP_TOOLCHAIN=stable
cargo test --frozen --all-features