summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathaniel Chin2023-11-15 15:09:15 +0800
committerNathaniel Chin2023-11-15 15:09:15 +0800
commit1b2cb64578f450c7d738c59a21f297bfe40418ff (patch)
tree2ebc7c0b287f827fb9b90919956528f4eecd2528
parent98e0c8484301dcd52f7556e8b198de6dca814df3 (diff)
downloadaur-1b2cb64578f450c7d738c59a21f297bfe40418ff.tar.gz
Update to 6.1
-rw-r--r--.SRCINFO20
-rw-r--r--040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch4
-rw-r--r--PKGBUILD20
3 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83b6156a1893..611cac876914 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-amd-full
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features for AMD)
- pkgver = 6.0
- pkgrel = 3
+ pkgver = 6.1
+ pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
license = custom: nonfree and unredistributable
@@ -126,22 +126,20 @@ pkgbase = ffmpeg-amd-full
provides = ffmpeg
provides = ffmpeg-full
conflicts = ffmpeg
- source = https://ffmpeg.org/releases/ffmpeg-6.0.tar.xz
- source = https://ffmpeg.org/releases/ffmpeg-6.0.tar.xz.asc
- source = 010-ffmpeg-add-svt-hevc-geb24a06.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/eb24a06ba4ee4948f219a3246b88439a8090bd37/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
- source = 030-ffmpeg-add-svt-vp9-gaaa8140.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/aaa8140c8cdf6c073eaa6aaa5d003d1535fd0059/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch
+ source = https://ffmpeg.org/releases/ffmpeg-6.1.tar.xz
+ source = https://ffmpeg.org/releases/ffmpeg-6.1.tar.xz.asc
+ source = 010-ffmpeg-add-svt-hevc-g6cca5b9.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/6cca5b932623d3a1953b165ae6b093ca1325ac44/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
+ source = 030-ffmpeg-add-svt-vp9-g43ef8e5.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/43ef8e5e96932421858762392adbbab57c84aebf/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
- source = 070-ffmpeg-binutils2.41-fix.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/effadce6c756247ea8bae32dc13bb3e6f464f0eb
source = LICENSE
validpgpkeys = FCF986EA15E6E293A5644F10B4322F04D67658D8
- sha256sums = 57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082
+ sha256sums = 488c76e57dd9b3bee901f71d5c95eaf1db4a5a31fe46a28654e837144207c270
sha256sums = SKIP
sha256sums = e8fdc940474f3819b9a8d30cab8164774584c051322acb6194bcb03d56e8175a
- sha256sums = d8b91ea5f07d0208cbe0290567083808708014a1953fda322d13cb619349c9ee
- sha256sums = d1ad786df86354d218a70b306a50961736c0a6e2d2716bf8de3db31d79957df9
+ sha256sums = 0433016c8523c7ce159523946a76c8fa06a926f33f94b70e8de7c2082d14178c
+ sha256sums = 7d5ce8058b143bae1be10a06d79ac0f1a72daf00cf648309450d83bea249a6b1
sha256sums = bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a
- sha256sums = fec03e133521486ca258ae34ddf093eb6aab23f848c4332c367aadbfeaefda04
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-amd-full
diff --git a/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch b/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
index b6eb1d7394b5..091a17a7dfdc 100644
--- a/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
+++ b/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
@@ -1,6 +1,6 @@
--- a/libavformat/avformat.h
+++ b/libavformat/avformat.h
-@@ -1019,6 +1019,10 @@ attribute_deprecated
+@@ -1030,6 +1030,10 @@ attribute_deprecated
int64_t av_stream_get_end_pts(const AVStream *st);
#endif
@@ -13,7 +13,7 @@
/**
--- a/libavformat/utils.c
+++ b/libavformat/utils.c
-@@ -55,6 +55,13 @@ int ff_unlock_avformat(void)
+@@ -56,6 +56,13 @@ int ff_unlock_avformat(void)
return ff_mutex_unlock(&avformat_mutex) ? -1 : 0;
}
diff --git a/PKGBUILD b/PKGBUILD
index 2a7acdf96c18..84bd9746c247 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Bruno Filipe < gmail-com: bmilreu >
pkgname=ffmpeg-amd-full
-pkgver=6.0
-pkgrel=3
+pkgver=6.1
+pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features for AMD)'
arch=('x86_64')
url='https://www.ffmpeg.org/'
@@ -123,23 +123,21 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libswscale.so' 'libswresample.so'
'ffmpeg' 'ffmpeg-full')
conflicts=('ffmpeg')
-_svt_hevc_ver='eb24a06ba4ee4948f219a3246b88439a8090bd37'
-_svt_vp9_ver='aaa8140c8cdf6c073eaa6aaa5d003d1535fd0059'
+_svt_hevc_ver='6cca5b932623d3a1953b165ae6b093ca1325ac44'
+_svt_vp9_ver='43ef8e5e96932421858762392adbbab57c84aebf'
source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
"010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
#"020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
"030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/${_svt_vp9_ver}/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch"
'040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
- '070-ffmpeg-binutils2.41-fix.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/effadce6c756247ea8bae32dc13bb3e6f464f0eb'
'LICENSE')
-sha256sums=('57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082'
+sha256sums=('488c76e57dd9b3bee901f71d5c95eaf1db4a5a31fe46a28654e837144207c270'
'SKIP'
'e8fdc940474f3819b9a8d30cab8164774584c051322acb6194bcb03d56e8175a'
- 'd8b91ea5f07d0208cbe0290567083808708014a1953fda322d13cb619349c9ee'
- 'd1ad786df86354d218a70b306a50961736c0a6e2d2716bf8de3db31d79957df9'
+ '0433016c8523c7ce159523946a76c8fa06a926f33f94b70e8de7c2082d14178c'
+ '7d5ce8058b143bae1be10a06d79ac0f1a72daf00cf648309450d83bea249a6b1'
'bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a'
- 'fec03e133521486ca258ae34ddf093eb6aab23f848c4332c367aadbfeaefda04'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
@@ -150,7 +148,6 @@ prepare() {
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/060-ffmpeg-fix-segfault-with-avisynthplus.patch"
- patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/070-ffmpeg-binutils2.41-fix.patch"
}
build() {
@@ -196,9 +193,10 @@ build() {
--enable-libdc1394 \
--enable-libfdk-aac \
--enable-libflite \
- --enable-fontconfig \
+ --enable-libfontconfig \
--enable-libfreetype \
--enable-libfribidi \
+ --enable-libharfbuzz \
--enable-libglslang \
--enable-libgme \
--enable-libgsm \