summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathaniel Chin2024-01-05 15:30:36 +0800
committerNathaniel Chin2024-01-05 15:30:36 +0800
commit7993e426b7efc9bac19baf68197a0607feed312a (patch)
treeaca2eade21d2dbd5a36105a43ccfc4c1a06f498b
parent1b2cb64578f450c7d738c59a21f297bfe40418ff (diff)
downloadaur-7993e426b7efc9bac19baf68197a0607feed312a.tar.gz
Update to 6.1.1 and fix build
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 611cac876914..4c5cc021f231 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-amd-full
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features for AMD)
- pkgver = 6.1
+ pkgver = 6.1.1
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = ffmpeg-amd-full
depends = alsa-lib
depends = aom
depends = aribb24
+ depends = libaribcaption
depends = avisynthplus
depends = bzip2
depends = celt
@@ -75,6 +76,7 @@ pkgbase = ffmpeg-amd-full
depends = ocl-icd
depends = openal
depends = opencore-amr
+ depends = opencv2
depends = openh264
depends = openjpeg2
depends = opus
@@ -108,7 +110,7 @@ pkgbase = ffmpeg-amd-full
depends = zvbi
depends = chromaprint-fftw
depends = davs2
- depends = libklvanc-git
+ depends = libklvanc
depends = librist
depends = shine
depends = uavs3d-git
@@ -126,20 +128,22 @@ pkgbase = ffmpeg-amd-full
provides = ffmpeg
provides = ffmpeg-full
conflicts = ffmpeg
- source = https://ffmpeg.org/releases/ffmpeg-6.1.tar.xz
- source = https://ffmpeg.org/releases/ffmpeg-6.1.tar.xz.asc
+ source = https://ffmpeg.org/releases/ffmpeg-6.1.1.tar.xz
+ source = https://ffmpeg.org/releases/ffmpeg-6.1.1.tar.xz.asc
source = 010-ffmpeg-add-svt-hevc-g6cca5b9.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/6cca5b932623d3a1953b165ae6b093ca1325ac44/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
source = 030-ffmpeg-add-svt-vp9-g43ef8e5.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/43ef8e5e96932421858762392adbbab57c84aebf/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
+ source = 070-ffmpeg-fix-lensfun-detection.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/e1c1dc8347f13104bc21e4100fcf4d4dddf5e5d8
source = LICENSE
validpgpkeys = FCF986EA15E6E293A5644F10B4322F04D67658D8
- sha256sums = 488c76e57dd9b3bee901f71d5c95eaf1db4a5a31fe46a28654e837144207c270
+ sha256sums = 8684f4b00f94b85461884c3719382f1261f0d9eb3d59640a1f4ac0873616f968
sha256sums = SKIP
sha256sums = e8fdc940474f3819b9a8d30cab8164774584c051322acb6194bcb03d56e8175a
sha256sums = 0433016c8523c7ce159523946a76c8fa06a926f33f94b70e8de7c2082d14178c
sha256sums = 7d5ce8058b143bae1be10a06d79ac0f1a72daf00cf648309450d83bea249a6b1
sha256sums = bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a
+ sha256sums = 2b72fe52ea73fbc1ce7eb70b4c181893c761e30121879ddd5513976232d7adf8
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-amd-full
diff --git a/PKGBUILD b/PKGBUILD
index 84bd9746c247..a90fd7bee908 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Bruno Filipe < gmail-com: bmilreu >
pkgname=ffmpeg-amd-full
-pkgver=6.1
+pkgver=6.1.1
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features for AMD)'
arch=('x86_64')
@@ -14,6 +14,7 @@ depends=(
'alsa-lib'
'aom'
'aribb24'
+ 'libaribcaption'
'avisynthplus'
'bzip2'
'celt'
@@ -75,6 +76,7 @@ depends=(
'ocl-icd'
'openal'
'opencore-amr'
+ 'opencv2'
'openh264'
'openjpeg2'
'opus'
@@ -108,7 +110,7 @@ depends=(
'zvbi'
'chromaprint-fftw'
'davs2'
- 'libklvanc-git'
+ 'libklvanc'
'librist'
'shine'
'uavs3d-git'
@@ -131,13 +133,15 @@ source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
"030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/${_svt_vp9_ver}/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch"
'040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
+ '070-ffmpeg-fix-lensfun-detection.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/e1c1dc8347f13104bc21e4100fcf4d4dddf5e5d8'
'LICENSE')
-sha256sums=('488c76e57dd9b3bee901f71d5c95eaf1db4a5a31fe46a28654e837144207c270'
+sha256sums=('8684f4b00f94b85461884c3719382f1261f0d9eb3d59640a1f4ac0873616f968'
'SKIP'
'e8fdc940474f3819b9a8d30cab8164774584c051322acb6194bcb03d56e8175a'
'0433016c8523c7ce159523946a76c8fa06a926f33f94b70e8de7c2082d14178c'
'7d5ce8058b143bae1be10a06d79ac0f1a72daf00cf648309450d83bea249a6b1'
'bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a'
+ '2b72fe52ea73fbc1ce7eb70b4c181893c761e30121879ddd5513976232d7adf8'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
@@ -148,6 +152,7 @@ prepare() {
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/060-ffmpeg-fix-segfault-with-avisynthplus.patch"
+ patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/070-ffmpeg-fix-lensfun-detection.patch"
}
build() {
@@ -181,6 +186,7 @@ build() {
--enable-lcms2 \
--enable-libaom \
--enable-libaribb24 \
+ --enable-libaribcaption \
--enable-libass \
--enable-libbluray \
--enable-libbs2b \
@@ -211,7 +217,7 @@ build() {
--enable-libmp3lame \
--enable-libopencore-amrnb \
--enable-libopencore-amrwb \
- --disable-libopencv \
+ --enable-libopencv \
--enable-libopenh264 \
--enable-libopenjpeg \
--enable-libopenmpt \