summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMushfiqur Rahman Abir2021-05-14 02:58:37 +0600
committerMushfiqur Rahman Abir2021-05-14 02:58:37 +0600
commit6982e04382ba7041a288c638c78f4e9ea109a746 (patch)
tree43eea8d6f0b122ce4d2eb437429e11c6f864d151
downloadaur-6982e04382ba7041a288c638c78f4e9ea109a746.tar.gz
Add ffmpeg coder initial pkgbuild
Why: To upload it and use it from AUR How: What: Tags: AUR, pkgbuild, arch
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD52
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..666d500bebe9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ffmpeg-coder
+ pkgdesc = A small cross platform CLI tool which will help in producing different types video converting codes quickly for new ffmpeg CLI users
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/Abir-Tx/ffmpeg-coder.git
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ optdepends = ffmpeg
+ provides = ffmpeg-coder
+ conflicts = ffmpeg-coder
+ source = git+https://github.com/Abir-Tx/ffmpeg-coder.git
+ md5sums = SKIP
+
+pkgname = ffmpeg-coder
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fbb0b2cf291
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Abir-Tx <abirtx@yandex.com>
+pkgname=ffmpeg-coder
+pkgver=2.0.0
+pkgrel=1
+epoch=
+pkgdesc="A small cross platform CLI tool which will help in producing different types video converting codes quickly for new ffmpeg CLI users"
+arch=(x86_64 i686)
+url="https://github.com/Abir-Tx/ffmpeg-coder.git"
+license=('MIT')
+groups=()
+depends=()
+makedepends=(git make gcc)
+optdepends=(ffmpeg)
+provides=(ffmpeg-coder)
+conflicts=(ffmpeg-coder)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname"
+ git switch aur
+ mkdir build && cd build
+ cmake ..
+}
+
+build() {
+ cd "$pkgname"
+ cd build
+ make
+}
+
+package() {
+ cd "$pkgname"
+ cd build
+ sudo make install
+ cd ..
+ install -Dm644 docs/README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}