summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-11-23 10:33:53 -0700
committerMark Wagie2021-11-23 10:33:53 -0700
commit6c5e1e04d4d6912bdbda0fc390f9cb5776cfa2e8 (patch)
treebee83641eb68db7254035c0b377b602a453a6e3b
parentdf89a57d743dae61a81fed2b0cc50c4ebff6197f (diff)
downloadaur-6c5e1e04d4d6912bdbda0fc390f9cb5776cfa2e8.tar.gz
4.4.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0707934b1b98..7c453e47f9f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = ffmpeg-cuda
pkgdesc = Complete solution to record, convert and stream audio and video. Includes cuda support.
- pkgver = 4.4
- pkgrel = 2
+ pkgver = 4.4.1
+ pkgrel = 1
epoch = 1
url = https://ffmpeg.org/
arch = x86_64
- license = GPL3
+ license = custom
makedepends = amf-headers
makedepends = avisynthplus
makedepends = clang
@@ -81,7 +81,7 @@ pkgbase = ffmpeg-cuda
provides = libswscale.so
provides = ffmpeg
conflicts = ffmpeg
- source = git+https://git.ffmpeg.org/ffmpeg.git#tag=dc91b913b6260e85e1304c74ff7bb3c22a8c9fb1
+ source = git+https://git.ffmpeg.org/ffmpeg.git#tag=7e0d640edf6c3eee1816b105c2f7498c4f948e74
source = vmaf-model-path.patch
sha256sums = SKIP
sha256sums = 8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d
diff --git a/PKGBUILD b/PKGBUILD
index b198ec4b69a3..0c91478fbd7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,13 +10,13 @@
# https://docs.nvidia.com/video-technologies/video-codec-sdk/ffmpeg-with-nvidia-gpu/
pkgname=ffmpeg-cuda
-pkgver=4.4
-pkgrel=2
+pkgver=4.4.1
+pkgrel=1
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video. Includes cuda support.'
arch=(x86_64)
url=https://ffmpeg.org/
-license=(GPL3)
+license=('custom')
depends=(
alsa-lib
aom
@@ -100,7 +100,7 @@ provides=(
ffmpeg
)
conflicts=('ffmpeg')
-_tag=dc91b913b6260e85e1304c74ff7bb3c22a8c9fb1
+_tag=7e0d640edf6c3eee1816b105c2f7498c4f948e74
source=(
git+https://git.ffmpeg.org/ffmpeg.git#tag=${_tag}
vmaf-model-path.patch
@@ -197,4 +197,6 @@ build() {
package() {
make DESTDIR="${pkgdir}" -C ffmpeg install install-man
install -Dm 755 ffmpeg/tools/qt-faststart "${pkgdir}"/usr/bin/
+
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}