summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-09-27 12:54:27 -0600
committerMark Wagie2021-09-27 12:54:27 -0600
commit78f8d364d9c322a254bac19310a054690cf38580 (patch)
tree6a441924b94d06ee8256c329b129f2c1e4551d07
parentcbd1327f4391e50739e3828809287a9d539fc051 (diff)
downloadaur-78f8d364d9c322a254bac19310a054690cf38580.tar.gz
override default nvccflags instead of using sed
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddced1559683..321bd4dbf7b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -120,13 +120,12 @@ prepare() {
cd ffmpeg
git cherry-pick -n 988f2e9eb063db7c1a678729f58aab6eba59a55b # fix nvenc on older gpus
patch -Np1 -i "${srcdir}"/vmaf-model-path.patch
-
- sed -i 's/arch=compute_30,code=sm_30/arch=compute_50,code=sm_50/g' configure
}
build() {
local _cflags='-I/opt/cuda/include'
local _ldflags='-L/opt/cuda/lib64'
+ local _nvccflags='-gencode arch=compute_50,code=sm_50 -O2'
cd ffmpeg
@@ -134,6 +133,7 @@ build() {
--prefix=/usr \
--extra-cflags="$_cflags" \
--extra-ldflags="$_ldflags" \
+ --nvccflags="$_nvccflags" \
--disable-debug \
--disable-static \
--disable-stripping \