summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhirui Dai2023-10-09 12:41:31 -0700
committerZhirui Dai2023-10-09 12:41:31 -0700
commit7e23c6871941fbad4d86e6236d518e4259c0eecc (patch)
tree9952dfae588a84e22bf35a6bc2f4f81c30ad7a81
parentcf935c602e42f48731c48435dadbebcbda386e42 (diff)
downloadaur-7e23c6871941fbad4d86e6236d518e4259c0eecc.tar.gz
6.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
2 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b49af5fd627..fc4b3a5de774 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-cuda
pkgdesc = Complete solution to record, convert and stream audio and video. Includes cuda support.
- pkgver = 5.1.2
+ pkgver = 6.0
pkgrel = 1
epoch = 1
url = https://ffmpeg.org/
@@ -90,10 +90,9 @@ pkgbase = ffmpeg-cuda
provides = libswscale.so
provides = ffmpeg
conflicts = ffmpeg
- source = git+https://git.ffmpeg.org/ffmpeg.git?signed#tag=1326fe9d4c85cca1ee774b072ef4fa337694f2e7
- source = add-av_stream_get_first_dts-for-chromium.patch
- validpgpkeys = DD1EC9E8DE085C629B3E1846B18E8928B3948D64
- b2sums = SKIP
- b2sums = 555274228e09a233d92beb365d413ff5c718a782008075552cafb2130a3783cf976b51dfe4513c15777fb6e8397a34122d475080f2c4483e8feea5c0d878e6de
+ source = ffmpeg-cuda-6.0.tar.xz::https://ffmpeg.org/releases/ffmpeg-6.0.tar.xz
+ source = libavcodec.patch
+ sha256sums = 57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082
+ sha256sums = 4a5cda5821a89527f764fe5a0404dada0e4058f4f6b1a7afe28c14229d3aee9f
pkgname = ffmpeg-cuda
diff --git a/PKGBUILD b/PKGBUILD
index d399e41ccaef..768761d692e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
# https://arnon.dk/matching-sm-architectures-arch-and-gencode-for-various-nvidia-cards/
pkgname=ffmpeg-cuda
-pkgver=5.1.2
+pkgver=6.0
pkgrel=1
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video. Includes cuda support.'
@@ -111,26 +111,23 @@ provides=(
ffmpeg
)
conflicts=('ffmpeg')
-_tag=1326fe9d4c85cca1ee774b072ef4fa337694f2e7
source=(
- "git+https://git.ffmpeg.org/ffmpeg.git?signed#tag=${_tag}"
- 'add-av_stream_get_first_dts-for-chromium.patch'
+ "${pkgname}-${pkgver}.tar.xz::https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"
+ 'libavcodec.patch'
+)
+sha256sums=(
+ "57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082"
+ "4a5cda5821a89527f764fe5a0404dada0e4058f4f6b1a7afe28c14229d3aee9f"
)
-b2sums=('SKIP'
- '555274228e09a233d92beb365d413ff5c718a782008075552cafb2130a3783cf976b51dfe4513c15777fb6e8397a34122d475080f2c4483e8feea5c0d878e6de')
-validpgpkeys=(DD1EC9E8DE085C629B3E1846B18E8928B3948D64) # Michael Niedermayer <michael@niedermayer.cc>
-
-pkgver() {
- cd ffmpeg
- git describe --tags | sed 's/^n//'
-}
+_dir=ffmpeg-${pkgver}
prepare() {
- cd ffmpeg
- patch -Np1 -i ../add-av_stream_get_first_dts-for-chromium.patch # https://crbug.com/1251779
+ cd $_dir
+ patch -p1 -i ${srcdir}/libavcodec.patch
}
build() {
+
local _cflags='-I/opt/cuda/include'
local _ldflags='-L/opt/cuda/lib64'
local _nvccflags='-gencode arch=compute_52,code=sm_52 -O2'
@@ -151,7 +148,7 @@ build() {
# -gencode arch=compute_89,code=compute_89 \
# -O2'
- cd ffmpeg
+ cd ${_dir}
./configure \
--prefix=/usr \
@@ -224,8 +221,8 @@ build() {
}
package() {
- make DESTDIR="${pkgdir}" -C ffmpeg install install-man
- install -Dm 755 ffmpeg/tools/qt-faststart "${pkgdir}"/usr/bin/
+ make DESTDIR="${pkgdir}" -C ${_dir} install install-man
+ install -Dm 755 ${_dir}/tools/qt-faststart "${pkgdir}"/usr/bin/
- install -Dm 644 ffmpeg/LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 ${_dir}/LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
}