summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-10-28 09:30:15 -0300
committerDaniel Bermond2023-10-28 09:30:15 -0300
commit8f951f18cf4d2b98a2d64c7a8d6434756fbeb60a (patch)
tree923183358aa547cf5fb6eac12bb87b960e9e78f5
parent983db021a71d55cfb4514a4c7e9344261494d6a3 (diff)
downloadaur-8f951f18cf4d2b98a2d64c7a8d6434756fbeb60a.tar.gz
Temporarily disable docs to fix build. Fix nvenc build.
HTML pages fails to build with texinfo 7.1. Temporarily disabling it until there is an upstream fix.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 13 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e40bb498dda5..e2283ea7001d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-decklink
pkgdesc = Complete solution to record, convert and stream audio and video (decklink enabled)
pkgver = 6.0
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -96,6 +96,8 @@ pkgbase = ffmpeg-decklink
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
source = 070-ffmpeg-binutils2.41-fix.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/effadce6c756247ea8bae32dc13bb3e6f464f0eb
+ source = 080-ffmpeg-nvenc-fix-010.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/03823ac0c6a38bd6ba972539e3203a592579792f
+ source = 090-ffmpeg-nvenc-fix-020.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/d2b46c1ef768bc31ba9180f6d469d5b8be677500
source = LICENSE
validpgpkeys = FCF986EA15E6E293A5644F10B4322F04D67658D8
sha256sums = 57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082
@@ -103,6 +105,8 @@ pkgbase = ffmpeg-decklink
sha256sums = d1ad786df86354d218a70b306a50961736c0a6e2d2716bf8de3db31d79957df9
sha256sums = bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a
sha256sums = fec03e133521486ca258ae34ddf093eb6aab23f848c4332c367aadbfeaefda04
+ sha256sums = aa8c43efac4c0dfc462af887b56bdb177cf09dd8b2dffea5c83a4dbfc35e0917
+ sha256sums = 3fe87a3bd193f16a191ff795ae8ad62d930e48d7b379fc627043717a6bdf3e93
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-decklink
diff --git a/PKGBUILD b/PKGBUILD
index a852c5f06146..34eb516126bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ffmpeg-decklink
pkgver=6.0
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video (decklink enabled)'
arch=('x86_64')
@@ -96,12 +96,16 @@ source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
'040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
'070-ffmpeg-binutils2.41-fix.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/effadce6c756247ea8bae32dc13bb3e6f464f0eb'
+ '080-ffmpeg-nvenc-fix-010.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/03823ac0c6a38bd6ba972539e3203a592579792f'
+ '090-ffmpeg-nvenc-fix-020.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/d2b46c1ef768bc31ba9180f6d469d5b8be677500'
'LICENSE')
sha256sums=('57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082'
'SKIP'
'd1ad786df86354d218a70b306a50961736c0a6e2d2716bf8de3db31d79957df9'
'bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a'
'fec03e133521486ca258ae34ddf093eb6aab23f848c4332c367aadbfeaefda04'
+ 'aa8c43efac4c0dfc462af887b56bdb177cf09dd8b2dffea5c83a4dbfc35e0917'
+ '3fe87a3bd193f16a191ff795ae8ad62d930e48d7b379fc627043717a6bdf3e93'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
@@ -109,6 +113,8 @@ prepare() {
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/060-ffmpeg-fix-segfault-with-avisynthplus.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/070-ffmpeg-binutils2.41-fix.patch"
+ patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/080-ffmpeg-nvenc-fix-010.patch"
+ patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/090-ffmpeg-nvenc-fix-020.patch"
}
build() {
@@ -120,6 +126,7 @@ build() {
--disable-debug \
--disable-static \
--disable-stripping \
+ --disable-htmlpages \
--enable-amf \
--enable-avisynth \
--enable-cuda-llvm \