summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-05-13 16:50:39 +0000
committerDaniel Bermond2018-05-13 16:50:39 +0000
commitce92f6ee1c8a9b2c12a8ebf21c734e2ddf9e520e (patch)
tree58580507441ae49ba6db6b732bde87bc4d292269
parent0706661068a669a2c2537d10d37e6299c5022772 (diff)
downloadaur-ce92f6ee1c8a9b2c12a8ebf21c734e2ddf9e520e.tar.gz
Match latest repository changes (notably nvidia hwaccel support)
Changes to match ffmpeg from official repository package in its 1:4.0-2 update: - add support for nvdec/nvenc/cuda/cuvid hardware acceleration by adding ffnvcodec-headers - remove jack support - remove avisynth - add libdrm - improve xlib dependencies by adding libxv and libxext References ---------- https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/ffmpeg&id=ccdc194edaa4617bc8730a48d62f1665cb23acc1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b3a40bb0f5f..2612185a2a1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = ffmpeg-decklink
pkgdesc = Complete solution to record, convert and stream audio and video (decklink enabled)
pkgver = 4.0
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = http://ffmpeg.org/
arch = i686
arch = x86_64
- license = custom:nonfree and unredistributable
+ license = custom: nonfree and unredistributable
makedepends = nasm
+ makedepends = ffnvcodec-headers
makedepends = ladspa
makedepends = blackmagic-decklink-sdk
depends = alsa-lib
@@ -18,11 +19,12 @@ pkgbase = ffmpeg-decklink
depends = gmp
depends = gnutls
depends = gsm
- depends = jack
depends = lame
depends = libavc1394
+ depends = libdrm
depends = libiec61883
depends = libmodplug
+ depends = libomxil-bellagio
depends = libpulse
depends = libraw1394
depends = libsoxr
@@ -32,7 +34,9 @@ pkgbase = ffmpeg-decklink
depends = libwebp
depends = libx11
depends = libxcb
+ depends = libxext
depends = libxml2
+ depends = libxv
depends = opencore-amr
depends = openjpeg2
depends = opus
@@ -41,7 +45,6 @@ pkgbase = ffmpeg-decklink
depends = v4l-utils
depends = xz
depends = zlib
- depends = libomxil-bellagio
depends = libass.so
depends = libbluray.so
depends = libfreetype.so
diff --git a/PKGBUILD b/PKGBUILD
index 6c0559c8cc5f..2439448a6e4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,24 @@
pkgname=ffmpeg-decklink
_srcname=ffmpeg
pkgver=4.0
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video (decklink enabled)'
arch=('i686' 'x86_64')
url='http://ffmpeg.org/'
-license=('custom:nonfree and unredistributable')
+license=('custom: nonfree and unredistributable')
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
- 'jack' 'lame' 'libavc1394' 'libiec61883' 'libmodplug' 'libpulse'
- 'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libvdpau' 'libwebp'
- 'libx11' 'libxcb' 'libxml2' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2'
- 'speex' 'v4l-utils' 'xz' 'zlib'
- 'libomxil-bellagio'
+ 'lame' 'libavc1394' 'libdrm' 'libiec61883' 'libmodplug'
+ 'libomxil-bellagio' 'libpulse' 'libraw1394' 'libsoxr' 'libssh'
+ 'libtheora' 'libvdpau' 'libwebp' 'libx11' 'libxcb' 'libxext' 'libxml2'
+ 'libxv' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2' 'speex' 'v4l-utils'
+ 'xz' 'zlib'
'libass.so' 'libbluray.so' 'libfreetype.so' 'libva-drm.so' 'libva.so'
'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so'
'libvpx.so' 'libx264.so' 'libx265.so' 'libxvidcore.so')
makedepends=(
# official repositories:
- 'nasm' 'ladspa'
+ 'nasm' 'ffnvcodec-headers' 'ladspa'
# AUR:
'blackmagic-decklink-sdk'
)
@@ -47,7 +47,6 @@ build() {
--disable-debug \
--disable-static \
--disable-stripping \
- --enable-avisynth \
--enable-avresample \
--enable-fontconfig \
--enable-gmp \
@@ -56,6 +55,7 @@ build() {
--enable-ladspa \
--enable-libass \
--enable-libbluray \
+ --enable-libdrm \
--enable-libfreetype \
--enable-libfribidi \
--enable-libgsm \
@@ -81,9 +81,11 @@ build() {
--enable-libxcb \
--enable-libxml2 \
--enable-libxvid \
+ --enable-nvdec \
+ --enable-nvenc \
+ --enable-omx \
--enable-shared \
--enable-version3 \
- --enable-omx \
--enable-nonfree \
--enable-decklink