summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-22 02:18:42 +0000
committerDaniel Bermond2020-04-22 02:19:55 +0000
commit0ea4af67c1fdc6724fbd03c10ed18b72d298d11c (patch)
tree83a0e476111e1de1c69ee62e6ffe98de169e6130
parent7de0b58e01aae377d07e26e18cb2b044991bc695 (diff)
downloadaur-0ea4af67c1fdc6724fbd03c10ed18b72d298d11c.tar.gz
Fix build with svt-av1 0.8.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb080c4d9600..9c7cd33813fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-full
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac)
pkgver = 4.2.2
- pkgrel = 3
+ pkgrel = 4
url = https://www.ffmpeg.org/
arch = x86_64
license = custom: nonfree and unredistributable
@@ -122,7 +122,7 @@ pkgbase = ffmpeg-full
source = https://ffmpeg.org/releases/ffmpeg-4.2.2.tar.xz.asc
source = ffmpeg-full-add-svt-hevc-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
source = ffmpeg-full-add-svt-hevc-docs-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch
- source = ffmpeg-full-add-svt-av1-0.8.1.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/v0.8.1/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch
+ source = ffmpeg-full-add-svt-av1-0.8.2.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/v0.8.2/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch
source = ffmpeg-full-add-svt-vp9-0.1.0.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/v0.1.0/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-svt-hevc-av1.patch
source = ffmpeg-full-add-decklink-11.5-support.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/f32f9231dd4f74d9f95eef575b838bdc3e06a234
source = LICENSE
@@ -131,7 +131,7 @@ pkgbase = ffmpeg-full
sha256sums = SKIP
sha256sums = 878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6
sha256sums = 1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0
- sha256sums = efbe348e0dad6b5f9fc501a34ff8304d82c2745ec9ac952e72f8549775c2fe78
+ sha256sums = d371366ceda9233c1b9a60c680878f567861b675605a8dae5c275d633c51ba9f
sha256sums = 7690a4f6bdc4a57e35c7ff5b6e87f2fe6d056d452eff9e767eaccff41832f4d7
sha256sums = d23dedb5a275d1d753d30fd544a46d5b609868ad5d384b9c8c2ecc1a02281828
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
diff --git a/PKGBUILD b/PKGBUILD
index 2d930fb0b129..ca878c904080 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
# Contributor: Iacopo Isimbaldi <isiachi@rhye.it>
_svt_hevc_ver='1.4.3'
-_svt_av1_ver='0.8.1'
+_svt_av1_ver='0.8.2'
_svt_vp9_ver='0.1.0'
pkgname=ffmpeg-full
pkgver=4.2.2
-pkgrel=3
+pkgrel=4
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac)'
arch=('x86_64')
url='https://www.ffmpeg.org/'
@@ -51,7 +51,7 @@ sha256sums=('cb754255ab0ee2ea5f66f8850e1bd6ad5cac1cd855d0a2f4990fb8c668b0d29c'
'SKIP'
'878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6'
'1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0'
- 'efbe348e0dad6b5f9fc501a34ff8304d82c2745ec9ac952e72f8549775c2fe78'
+ 'd371366ceda9233c1b9a60c680878f567861b675605a8dae5c275d633c51ba9f'
'7690a4f6bdc4a57e35c7ff5b6e87f2fe6d056d452eff9e767eaccff41832f4d7'
'd23dedb5a275d1d753d30fd544a46d5b609868ad5d384b9c8c2ecc1a02281828'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
@@ -59,6 +59,8 @@ validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
prepare() {
# add svt codec support for hevc, av1 and vp9
+ rm -f "ffmpeg-${pkgver}/libavcodec/"libsvt_{hevc,av1,vp9}.c
+ sed -i 's/eb_init_handle/svt_av1_enc_init_handle/' "ffmpeg-full-add-svt-vp9-${_svt_vp9_ver}.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/ffmpeg-full-add-svt-hevc-${_svt_hevc_ver}.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/ffmpeg-full-add-svt-hevc-docs-${_svt_hevc_ver}.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/ffmpeg-full-add-svt-av1-${_svt_av1_ver}.patch"