summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-08-12 10:36:01 -0300
committerDaniel Bermond2023-08-12 10:36:01 -0300
commit2d968f031e6913fd5b045bc47c638b1a97d06b0f (patch)
tree8ce60a1b70af45f207219d41f363e3480e92031c
parent3782691a22346e8a40f883fcdc3d4f40c189a306 (diff)
downloadaur-2d968f031e6913fd5b045bc47c638b1a97d06b0f.tar.gz
Fix build with binutils 2.41
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f025b1664257..7163a88af285 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-full
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac)
pkgver = 6.0
- pkgrel = 3
+ pkgrel = 4
url = https://www.ffmpeg.org/
arch = x86_64
license = custom: nonfree and unredistributable
@@ -136,6 +136,7 @@ pkgbase = ffmpeg-full
source = 030-ffmpeg-add-svt-vp9-gaaa8140.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/aaa8140c8cdf6c073eaa6aaa5d003d1535fd0059/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
+ source = 070-ffmpeg-binutils2.41-fix.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/effadce6c756247ea8bae32dc13bb3e6f464f0eb
source = LICENSE
validpgpkeys = FCF986EA15E6E293A5644F10B4322F04D67658D8
sha256sums = 57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082
@@ -144,6 +145,7 @@ pkgbase = ffmpeg-full
sha256sums = d8b91ea5f07d0208cbe0290567083808708014a1953fda322d13cb619349c9ee
sha256sums = d1ad786df86354d218a70b306a50961736c0a6e2d2716bf8de3db31d79957df9
sha256sums = bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a
+ sha256sums = fec03e133521486ca258ae34ddf093eb6aab23f848c4332c367aadbfeaefda04
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-full
diff --git a/PKGBUILD b/PKGBUILD
index 200f83e01df4..644cb5626b38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ffmpeg-full
pkgver=6.0
-pkgrel=3
+pkgrel=4
_svt_hevc_ver='eb24a06ba4ee4948f219a3246b88439a8090bd37'
_svt_vp9_ver='aaa8140c8cdf6c073eaa6aaa5d003d1535fd0059'
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac)'
@@ -132,6 +132,7 @@ source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
"030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/${_svt_vp9_ver}/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch"
'040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
+ '070-ffmpeg-binutils2.41-fix.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/effadce6c756247ea8bae32dc13bb3e6f464f0eb'
'LICENSE')
sha256sums=('57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082'
'SKIP'
@@ -139,6 +140,7 @@ sha256sums=('57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082'
'd8b91ea5f07d0208cbe0290567083808708014a1953fda322d13cb619349c9ee'
'd1ad786df86354d218a70b306a50961736c0a6e2d2716bf8de3db31d79957df9'
'bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a'
+ 'fec03e133521486ca258ae34ddf093eb6aab23f848c4332c367aadbfeaefda04'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
@@ -149,6 +151,7 @@ prepare() {
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/060-ffmpeg-fix-segfault-with-avisynthplus.patch"
+ patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/070-ffmpeg-binutils2.41-fix.patch"
}
build() {