summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-11-09 16:00:01 -0200
committerDaniel Bermond2017-11-09 16:00:01 -0200
commit4b991aa9e31af8c6696167dbed24447bbf3f8d64 (patch)
tree9636c703ea6195ed8bd66c944cbf2b08c0997c94
parent279625e2298bc3771534c3e2cbb504a7acd10678 (diff)
downloadaur-4b991aa9e31af8c6696167dbed24447bbf3f8d64.tar.gz
Fix build in i686 architecture
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee4099afb4ac..5a3c7c3879c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Nov 9 17:58:29 UTC 2017
+# Thu Nov 9 17:59:50 UTC 2017
pkgbase = ffmpeg-full
pkgdesc = Record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac)
pkgver = 3.4
- pkgrel = 3
+ pkgrel = 4
url = http://www.ffmpeg.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d94fc4108e43..f70a9344970c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=ffmpeg-full
_srcname=ffmpeg
pkgver=3.4
-pkgrel=3
+pkgrel=4
pkgdesc='Record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac)'
arch=('i686' 'x86_64')
url='http://www.ffmpeg.org/'
@@ -65,7 +65,7 @@ build() {
local _cudasdk='--enable-cuda-sdk'
local _cuvid='--enable-cuvid'
local _libnpp='--enable-libnpp'
- local _cflags='--extra-cflags=-I/opt/cuda/include'
+ local _cflags='-I/opt/cuda/include'
# '-L/usr/lib/nvidia' (for cuda_sdk) needs to be enabled only on
# systems with nvidia-340xx-utils or nvidia-304xx-utils
@@ -74,7 +74,8 @@ build() {
then
local _nvidia_340xx_ldflags='-L/usr/lib/nvidia'
fi
- local _ldflags="--extra-ldflags=-L/opt/cuda/lib64 ${_nvidia_340xx_ldflags}"
+
+ local _ldflags="-L/opt/cuda/lib64 ${_nvidia_340xx_ldflags}"
local _ldflags="${_ldflags} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64:/opt/intel/mediasdk/plugins"
# strictly specifying nvcc path is needed if package is installing
@@ -86,8 +87,8 @@ build() {
./configure \
--prefix='/usr' \
- $_cflags \
- "$_ldflags" \
+ --extra-cflags="${_cflags}" \
+ --extra-ldflags="${_ldflags}" \
\
--disable-rpath \
--enable-gpl \