summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-09-17 14:32:11 +0000
committerDaniel Bermond2020-09-17 14:32:11 +0000
commit40ba9358a0bfbe5d9944072621eb9264e30dcce8 (patch)
tree87be3398a71c23931ad13ef85ccc7e0df7007ca0
parentbd252d99089862a9c74d43a88837d243c52de38e (diff)
downloadaur-ffmpeg-full-git.tar.gz
Disable rockchip mpp
Upstream repository for rockchip mpp is gone. It was at: https://github.com/rockchip-linux/mpp/ I could not find any upstream word about it. The Rockchip Wiki still points to this repository, without saying if it was really dropped or moved to another place. Due to this, new users now cannot build rockchip-mpp package. Disabling it so new users can build ffmpeg-full-git.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34f299268bb..889459abe8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
- pkgver = 4.4.r99044.gd1f3d721df
+ pkgver = 4.4.r99218.g0ea2bda099
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -114,7 +114,6 @@ pkgbase = ffmpeg-full-git
depends = xavs
depends = xavs2
depends = pocketsphinx
- depends = rockchip-mpp
provides = libavcodec.so
provides = libavdevice.so
provides = libavfilter.so
diff --git a/PKGBUILD b/PKGBUILD
index a07f598eded..2ba41931b38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _svt_hevc_ver='ead6fdf7c9ff84511b42fc1658c1654b84d83e4b'
_svt_vp9_ver='0.2.2'
pkgname=ffmpeg-full-git
-pkgver=4.4.r99044.gd1f3d721df
+pkgver=4.4.r99218.g0ea2bda099
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)'
arch=('x86_64')
@@ -28,7 +28,6 @@ depends=(
# AUR:
'chromaprint-fftw' 'davs2' 'flite1-patched' 'libklvanc-git' 'openh264'
'libopenmpt-svn' 'shine' 'vo-amrwbenc' 'xavs' 'xavs2' 'pocketsphinx'
- 'rockchip-mpp'
)
makedepends=(
# official repositories:
@@ -210,7 +209,7 @@ build() {
--enable-nvdec \
--enable-nvenc \
--enable-omx \
- --enable-rkmpp \
+ --disable-rkmpp \
--enable-v4l2-m2m \
--enable-vaapi \
--enable-vdpau