summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-10 01:38:26 +0000
committerDaniel Bermond2018-11-10 01:38:26 +0000
commit887df6f53290db280cb131a8db22edab79c9e339 (patch)
tree11ebef983b33ab20c7ee24db9ca3598e8a6d20df
parent2da79b7e7abbdc07fe768fa9f188c0f6bcf037ba (diff)
downloadaur-887df6f53290db280cb131a8db22edab79c9e339.tar.gz
Various changes
- use https for url - do not rename source clone - remove the setting of nvcc path on prepare() (now handled by makepkg) - pkgver(): declare and assign variables separately - new upstream options: --enable-{libdav1d,libklvanc,libxavs2}
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD47
2 files changed, 36 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d0ec7e91463..9d334c6ec268 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)
- pkgver = 4.1.r92192.g57f312a34d
+ pkgver = 4.2.r92394.g75625c555c
pkgrel = 1
- url = http://www.ffmpeg.org/
+ url = https://www.ffmpeg.org/
arch = i686
arch = x86_64
license = custom: nonfree and unredistributable
@@ -90,32 +90,35 @@ pkgbase = ffmpeg-full-git
depends = libvdpau
depends = chromaprint-fftw
depends = codec2
+ depends = dav1d-git
depends = davs2-git
depends = flite1-patched
depends = libilbc
+ depends = libklvanc-git
depends = kvazaar
depends = openh264
depends = libopenmpt-svn
depends = shine
depends = vo-amrwbenc
depends = xavs
+ depends = xavs2-git
depends = ndi-sdk
depends = libmysofa
depends = rockchip-mpp
- provides = ffmpeg
- provides = ffmpeg-full
- provides = ffmpeg-git
- provides = libavutil.so
provides = libavcodec.so
- provides = libavformat.so
provides = libavdevice.so
provides = libavfilter.so
+ provides = libavformat.so
+ provides = libavutil.so
+ provides = libpostproc.so
provides = libavresample.so
provides = libswscale.so
provides = libswresample.so
- provides = libpostproc.so
+ provides = ffmpeg
+ provides = ffmpeg-full
+ provides = ffmpeg-git
conflicts = ffmpeg
- source = ffmpeg-full-git::git://source.ffmpeg.org/ffmpeg.git
+ source = git://source.ffmpeg.org/ffmpeg.git
source = LICENSE
sha256sums = SKIP
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
diff --git a/PKGBUILD b/PKGBUILD
index 1a454edbe289..23386b089593 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=ffmpeg-full-git
-pkgver=4.1.r92192.g57f312a34d
+_srcname=ffmpeg
+pkgver=4.2.r92394.g75625c555c
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)'
arch=('i686' 'x86_64')
-url='http://www.ffmpeg.org/'
+url='https://www.ffmpeg.org/'
license=('custom: nonfree and unredistributable')
depends=(
# official repositories:
@@ -21,9 +22,9 @@ depends=(
'openal' 'ocl-icd' 'libgl' 'sndio' 'sdl2' 'vapoursynth' 'libxv' 'libx11'
'libxext' 'zlib' 'libomxil-bellagio' 'libva' 'libdrm' 'libvdpau'
# AUR:
- 'chromaprint-fftw' 'codec2' 'davs2-git' 'flite1-patched' 'libilbc' 'kvazaar'
- 'openh264' 'libopenmpt-svn' 'shine' 'vo-amrwbenc' 'xavs' 'ndi-sdk' 'libmysofa'
- 'rockchip-mpp'
+ 'chromaprint-fftw' 'codec2' 'dav1d-git' 'davs2-git' 'flite1-patched' 'libilbc'
+ 'libklvanc-git' 'kvazaar' 'openh264' 'libopenmpt-svn' 'shine' 'vo-amrwbenc'
+ 'xavs' 'xavs2-git' 'ndi-sdk' 'libmysofa' 'rockchip-mpp'
)
depends_x86_64=(
# official repositories:
@@ -41,35 +42,31 @@ makedepends_x86_64=(
# AUR:
'vmaf'
)
-provides=('ffmpeg' 'ffmpeg-full' 'ffmpeg-git' 'libavutil.so' 'libavcodec.so'
- 'libavformat.so' 'libavdevice.so' 'libavfilter.so' 'libavresample.so'
- 'libswscale.so' 'libswresample.so' 'libpostproc.so')
+provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+ 'libavutil.so' 'libpostproc.so' 'libavresample.so' 'libswscale.so'
+ 'libswresample.so' 'ffmpeg' 'ffmpeg-full' 'ffmpeg-git')
conflicts=('ffmpeg')
-source=("$pkgname"::'git://source.ffmpeg.org/ffmpeg.git'
+source=('git://source.ffmpeg.org/ffmpeg.git'
'LICENSE')
sha256sums=('SKIP'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
-prepare() {
- cd "$pkgname"
-
- # strictly specifying nvcc path is needed if package is installing
- # cuda for the first time (nvcc path will be in $PATH only after relogin)
- sed -i "s|^nvcc_default=.*|nvcc_default='/opt/cuda/bin/nvcc'|" configure
-}
-
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
+
+ local _version
+ local _revision
+ local _shorthash
- local _version="$( git describe --tags --long | awk -F'-' '{ printf $1 }' | sed 's/^n//')"
- local _revision="$( git describe --tags --match 'N' | awk -F'-' '{ printf $2 }')"
- local _shorthash="$(git rev-parse --short HEAD)"
+ _version="$( git describe --tags --long | awk -F'-' '{ printf $1 }' | sed 's/^n//')"
+ _revision="$( git describe --tags --match 'N' | awk -F'-' '{ printf $2 }')"
+ _shorthash="$(git rev-parse --short HEAD)"
printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
build() {
- cd "$pkgname"
+ cd "$_srcname"
# set x86_64 specific options
if [ "$CARCH" = 'x86_64' ]
@@ -105,6 +102,7 @@ build() {
--enable-nonfree \
--enable-shared \
--disable-static \
+ --disable-stripping \
--enable-gray \
--enable-avresample \
\
@@ -126,6 +124,7 @@ build() {
--enable-libcelt \
--enable-libcdio \
--enable-libcodec2 \
+ --enable-libdav1d \
--enable-libdavs2 \
--enable-libdc1394 \
--enable-libfdk-aac \
@@ -138,6 +137,7 @@ build() {
--enable-libiec61883 \
--enable-libilbc \
--enable-libjack \
+ --enable-libklvanc \
--enable-libkvazaar \
--enable-liblensfun \
--enable-libmodplug \
@@ -176,6 +176,7 @@ build() {
--enable-libx264 \
--enable-libx265 \
--enable-libxavs \
+ --enable-libxavs2 \
--enable-libxcb \
--enable-libxcb-shm \
--enable-libxcb-xfixes \
@@ -221,7 +222,7 @@ build() {
}
package() {
- cd "$pkgname"
+ cd "$_srcname"
make DESTDIR="$pkgdir" install