summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-06-27 00:51:44 +0000
committerDaniel Bermond2020-06-27 01:03:03 +0000
commit8f9bff8de0df502a0a13f2d243c6ae018e67603c (patch)
treeac937d169bee48b8782b931026cdba0f79ea737e
parent65fe55d5a96df9e0fb282e8f0b504b29a85679ca (diff)
downloadaur-8f9bff8de0df502a0a13f2d243c6ae018e67603c.tar.gz
Bring back svt-av1. Temporarily disable srt (broken by upstream).
Upstream svt-av1 has provided support for the recent API changes of ffmpeg git master[1], so it can be added again. Upstream srt recently introduced a commit[2] that removes deprecated API and breaks ffmpeg support. Bug reports were opened upstream at srt[3] and ffmpeg[4], and it's up to ffmpeg to fix it. Unfortunatelly it was marked as a 'wish' at the ffmpeg bug tracker, so it can take very long to be fixed. References ---------- [1] https://github.com/OpenVisualCloud/SVT-AV1/commit/b255a71cf47038ec73873ae507a56bc9fdef7c8f [2] https://github.com/Haivision/srt/commit/0e2201aff6b379979cec43fee5e8f162717f6346 [3] https://github.com/Haivision/srt/issues/1382 [4] https://trac.ffmpeg.org/ticket/8760
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a32087ea07b..2adb9f2c0352 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
- pkgver = 4.4.r98262.g23d06f606e
+ pkgver = 4.4.r98323.gb35968e060
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -59,9 +59,9 @@ pkgbase = ffmpeg-full-git
depends = snappy
depends = libsoxr
depends = speex
- depends = srt
depends = libssh
depends = svt-hevc
+ depends = svt-av1
depends = tensorflow
depends = tesseract
depends = libtheora
@@ -131,11 +131,13 @@ pkgbase = ffmpeg-full-git
source = 010-ffmpeg-fix-vmaf-model-path.patch
source = 020-ffmpeg-add-svt-hevc-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
source = 030-ffmpeg-add-svt-hevc-docs-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch
+ source = 040-ffmpeg-add-svt-av1-g7341224.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/7341224705ca83ae5f7a0ee78777e981b4656754/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1.patch
source = LICENSE
sha256sums = SKIP
sha256sums = b6fcef2f4cbb1daa47d17245702fbd67ab3289b6b16f090ab99b9c2669453a02
sha256sums = 878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6
sha256sums = 1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0
+ sha256sums = 09842ef78c66f39280ca62c9f6e14f9192ab253989ef23eefc52b3bf89d45bef
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-full-git
diff --git a/PKGBUILD b/PKGBUILD
index bb6dd14e039c..a83284964bc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
_svt_hevc_ver='1.4.3'
+_svt_av1_ver='7341224705ca83ae5f7a0ee78777e981b4656754'
pkgname=ffmpeg-full-git
-pkgver=4.4.r98262.g23d06f606e
+pkgver=4.4.r98323.gb35968e060
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)'
arch=('x86_64')
@@ -17,7 +18,7 @@ depends=(
'fontconfig' 'freetype2' 'fribidi' 'glslang' 'libgme' 'gsm' 'libiec61883'
'libilbc' 'jack' 'kvazaar' 'lensfun' 'libmodplug' 'lame' 'opencore-amr'
'openjpeg2' 'opus' 'pulseaudio' 'librabbitmq-c' 'rav1e' 'librsvg' 'rubberband'
- 'rtmpdump' 'snappy' 'libsoxr' 'speex' 'srt' 'libssh' 'svt-hevc'
+ 'rtmpdump' 'snappy' 'libsoxr' 'speex' 'libssh' 'svt-hevc' 'svt-av1'
'tensorflow' 'tesseract' 'libtheora' 'twolame' 'v4l-utils'
'vid.stab' 'vmaf' 'libvorbis' 'libvpx' 'wavpack' 'libwebp' 'x264' 'x265'
'libxcb' 'xvidcore' 'libxml2' 'zimg' 'zeromq' 'zvbi' 'lv2' 'lilv' 'xz'
@@ -43,11 +44,13 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git'
'010-ffmpeg-fix-vmaf-model-path.patch'
"020-ffmpeg-add-svt-hevc-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
"030-ffmpeg-add-svt-hevc-docs-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
+ "040-ffmpeg-add-svt-av1-g${_svt_av1_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/${_svt_av1_ver}/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1.patch"
'LICENSE')
sha256sums=('SKIP'
'b6fcef2f4cbb1daa47d17245702fbd67ab3289b6b16f090ab99b9c2669453a02'
'878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6'
'1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0'
+ '09842ef78c66f39280ca62c9f6e14f9192ab253989ef23eefc52b3bf89d45bef'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
prepare() {
@@ -55,6 +58,7 @@ prepare() {
patch -d ffmpeg -Np1 -i "${srcdir}/010-ffmpeg-fix-vmaf-model-path.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/020-ffmpeg-add-svt-hevc-${_svt_hevc_ver}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/030-ffmpeg-add-svt-hevc-docs-${_svt_hevc_ver}.patch"
+ patch -d ffmpeg -Np1 -i "${srcdir}/040-ffmpeg-add-svt-av1-g${_svt_av1_ver:0:7}.patch"
}
pkgver() {
@@ -136,6 +140,7 @@ build() {
--enable-libmp3lame \
--enable-libopencore-amrnb \
--enable-libopencore-amrwb \
+ --enable-libsvtav1 \
--disable-libopencv \
--enable-libopenh264 \
--enable-libopenjpeg \
@@ -152,7 +157,7 @@ build() {
--enable-libsnappy \
--enable-libsoxr \
--enable-libspeex \
- --enable-libsrt \
+ --disable-libsrt \
--enable-libssh \
--enable-libsvthevc \
--enable-libtensorflow \