summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-04-15 15:11:55 +0000
committerDaniel Bermond2018-04-15 17:49:59 +0000
commitc02256bab03a64b58a900c1a514a35456b2d4090 (patch)
treeae93bcba510cc81b27fd6ad6db97bbb8b386f954
parenta57553ab08c7af23735921498c4393e320b0553b (diff)
downloadaur-c02256bab03a64b58a900c1a514a35456b2d4090.tar.gz
makedepends: switch libmfx to intel-media-sdk
intel-media-sdk, the open source version of intel-media-server-studio, has now reached an acceptable stable release that can be used here to provide libmfx. This brings 2 important results: 1) The experimental state can be removed from the Intel QSV support, since intel-media-sdk also provides libmfxhw64 and plugins for hardware accelerated decode and encode. 2) Finally we can get rid of the unsecure rpath in ffmpeg binaries! intel-media-sdk is now a makedepend, instead of an optdepend as previously. If fact, I should have switched it to intel-media-server-studio in optdepends some time ago when it has changed to the open source version, but I letted this way while waiting for an acceptable stable release of, which taked a while to happen. Users should remove the libmfx{-git} package and stay only with intel-media-sdk{-git} package, since the former is the complete solution with the dispatcher library (libmfx.a), libmfxhw64 and plugins. Note1: ------ For the proper use of Intel QSV in ffmpeg the user must set the vaapi/libva driver to 'iHD' through the 'LIBVA_DRIVER_NAME' environment variable. The 'iHD' vaapi/libva driver is provided by intel-media-driver{-git} package, which at the current time is already a dependency of intel-media-sdk{-git} package. Setting the vaapi/libva driver to 'iHD' can be done, for example, by uncommenting the proper line in '/etc/profile.d/intel-media.sh'. Note2: ------ intel-media-sdk is currently at a pre-release state. This can lead to bugs when using Intel QSV. Note3: ------ Not all Intel platforms are supported by intel-media-sdk. At the current time, it claims to support only 5th and 6th Generation Intel® Core™ processors (Broadwell and Skylake). For details, please see the MediaSDK and media-driver documentation: - https://github.com/Intel-Media-SDK/MediaSDK/ - https://github.com/intel/media-driver/ Note4: ------ Intel QSV is available in x86_64 systems only. Also in this commit: -------------------- - depends: moved 'libbs2b' and 'sndio' from the AUR section to the official repositories section, since they are now at the [community] official repository.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD33
2 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51ba97128551..d8a1cab0e9f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)
- pkgver = 3.5.r90534.g33bd2b99a1
+ pkgver = 3.5.r90720.gedecd723f3
pkgrel = 1
url = http://www.ffmpeg.org/
arch = i686
@@ -11,7 +11,6 @@ pkgbase = ffmpeg-full-git
makedepends = opencl-headers
makedepends = blackmagic-decklink-sdk
makedepends = ffnvcodec-headers
- makedepends = libmfx
depends = glibc
depends = alsa-lib
depends = jack
@@ -24,6 +23,7 @@ pkgbase = ffmpeg-full-git
depends = ladspa
depends = libass
depends = libbluray
+ depends = libbs2b
depends = libcaca
depends = celt
depends = libcdio-paranoia
@@ -73,6 +73,7 @@ pkgbase = ffmpeg-full-git
depends = openal
depends = opencl-icd-loader
depends = mesa
+ depends = sndio
depends = sdl2
depends = libx11
depends = zlib
@@ -82,14 +83,12 @@ pkgbase = ffmpeg-full-git
depends = libvdpau
depends = chromaprint-fftw
depends = aom-git
- depends = libbs2b
depends = codec2
depends = flite1-patched
depends = libilbc
depends = kvazaar
depends = openh264
depends = libopenmpt-svn
- depends = sndio
depends = shine
depends = vo-amrwbenc
depends = xavs
@@ -130,8 +129,8 @@ pkgbase = ffmpeg-full-git
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
depends_x86_64 = cuda
depends_x86_64 = nvidia-utils
- optdepends_x86_64 = intel-media-sdk: for Intel QSV support (experimental)
makedepends_x86_64 = vmaf-git
+ makedepends_x86_64 = intel-media-sdk
pkgname = ffmpeg-full-git
diff --git a/PKGBUILD b/PKGBUILD
index b56a9c61dceb..c5142a1b2aa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=ffmpeg-full-git
-pkgver=3.5.r90534.g33bd2b99a1
+pkgver=3.5.r90720.gedecd723f3
pkgrel=1
pkgdesc='Record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)'
arch=('i686' 'x86_64')
@@ -11,33 +11,29 @@ depends=(
# official repositories:
'glibc' 'alsa-lib' 'jack' 'libpng'
'bzip2' 'frei0r-plugins' 'libgcrypt' 'gmp' 'gnutls' 'ladspa' 'libass'
- 'libbluray' 'libcaca' 'celt' 'libcdio-paranoia' 'libdc1394' 'libavc1394'
- 'libfdk-aac' 'fontconfig' 'freetype2' 'fribidi' 'libgme' 'gsm' 'libiec61883'
- 'libmodplug' 'lame' 'opencore-amr' 'openjpeg2' 'opus' 'pulseaudio'
+ 'libbluray' 'libbs2b' 'libcaca' 'celt' 'libcdio-paranoia' 'libdc1394'
+ 'libavc1394' 'libfdk-aac' 'fontconfig' 'freetype2' 'fribidi' 'libgme' 'gsm'
+ 'libiec61883' 'libmodplug' 'lame' 'opencore-amr' 'openjpeg2' 'opus' 'pulseaudio'
'librsvg' 'rubberband' 'rtmpdump' 'smbclient' 'snappy' 'libsoxr' 'speex' 'srt'
'libssh' 'tesseract' 'libtheora' 'twolame' 'v4l-utils' 'vid.stab' 'libvorbis'
'libvpx' 'wavpack' 'libwebp' 'libx264.so' 'x265' 'libxcb' 'xvidcore' 'libxml2'
- 'zimg' 'zeromq' 'zvbi' 'lilv' 'xz' 'openal' 'opencl-icd-loader' 'mesa' 'sdl2'
- 'libx11' 'zlib' 'libomxil-bellagio' 'libva' 'libdrm' 'libvdpau'
+ 'zimg' 'zeromq' 'zvbi' 'lilv' 'xz' 'openal' 'opencl-icd-loader' 'mesa' 'sndio'
+ 'sdl2' 'libx11' 'zlib' 'libomxil-bellagio' 'libva' 'libdrm' 'libvdpau'
# AUR:
- 'chromaprint-fftw' 'aom-git' 'libbs2b' 'codec2' 'flite1-patched' 'libilbc'
- 'kvazaar' 'openh264' 'libopenmpt-svn' 'sndio' 'shine' 'vo-amrwbenc' 'xavs'
- 'ndi-sdk' 'libmysofa' 'rockchip-mpp'
+ 'chromaprint-fftw' 'aom-git' 'codec2' 'flite1-patched' 'libilbc' 'kvazaar'
+ 'openh264' 'libopenmpt-svn' 'shine' 'vo-amrwbenc' 'xavs' 'ndi-sdk' 'libmysofa'
+ 'rockchip-mpp'
)
depends_x86_64=('cuda' 'nvidia-utils')
-optdepends_x86_64=(
- # AUR:
- 'intel-media-sdk: for Intel QSV support (experimental)'
-)
makedepends=(
# official repositories:
'git' 'nasm' 'opencl-headers'
# AUR:
- 'blackmagic-decklink-sdk' 'ffnvcodec-headers' 'libmfx'
+ 'blackmagic-decklink-sdk' 'ffnvcodec-headers'
)
makedepends_x86_64=(
# AUR:
- 'vmaf-git'
+ 'vmaf-git' 'intel-media-sdk'
)
provides=(
'ffmpeg' 'qt-faststart' 'ffmpeg-git' 'ffmpeg-decklink' 'ffmpeg-libfdk_aac' 'ffmpeg-nvenc'
@@ -80,19 +76,20 @@ build() {
then
local _libvmaf='--enable-libvmaf'
local _cudasdk='--enable-cuda-sdk'
+ local _libmfx='--enable-libmfx'
local _libnpp='--enable-libnpp'
local _cflags='-I/opt/cuda/include'
local _ldflags='-L/opt/cuda/lib64'
+ export PKG_CONFIG_PATH="${PKG_CONFIG_PATH:+${PKG_CONFIG_PATH}:}/opt/intel/mediasdk/lib64/pkgconfig"
+
# set path of -lcuda (libcuda.so.x, required by cuda_sdk)
# on systems with legacy nvidia drivers
if pacman -Qs '^nvidia-340xx-utils' >/dev/null 2>&1
then
_ldflags="${_ldflags} -L/usr/lib/nvidia"
fi
-
- _ldflags="${_ldflags} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64:/opt/intel/mediasdk/plugins"
fi
msg2 'Running ffmpeg configure script. Please wait...'
@@ -204,7 +201,7 @@ build() {
--enable-cuvid \
--enable-ffnvcodec \
--enable-libdrm \
- --enable-libmfx \
+ $_libmfx \
$_libnpp \
--enable-nvdec \
--enable-nvenc \