summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2015-08-04 14:32:52 +0500
committerDmitry Kharitonov2015-08-04 14:32:52 +0500
commit4233955a936b614102798df99c2a8ebc739eb0b3 (patch)
tree624e862a57194fad6d094be1398ef8e0daefc74c
parent43a8b9a763f5fae3200adbacf66eaa4ea1957eb6 (diff)
downloadaur-4233955a936b614102798df99c2a8ebc739eb0b3.tar.gz
Add nvenc-api makedependency and CUDA optdependency
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD3
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efcaef3dec6c..23cbf1dee29d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,10 +8,11 @@ pkgbase = ffmpeg-full-nvenc
arch = x86_64
license = GPL
license = custom:UNREDISTRIBUTABLE
- makedepends = libvdpau
- makedepends = yasm
makedepends = hardening-wrapper
+ makedepends = libvdpau
+ makedepends = nvenc-api
makedepends = opencl-headers
+ makedepends = yasm
depends = alsa-lib
depends = bzip2
depends = celt
@@ -72,6 +73,7 @@ pkgbase = ffmpeg-full-nvenc
depends = libx264.so
depends = libx265.so
optdepends = avxsynth-git: for Avisynth support
+ optdepends = cuda: for CUDA support
optdepends = opencl-nvidia: for OpenCL support
provides = libavcodec.so
provides = libavdevice.so
diff --git a/PKGBUILD b/PKGBUILD
index 66f941af3ef7..54446a87a911 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,8 +24,9 @@ depends=('alsa-lib' 'bzip2' 'celt' 'faac' 'fontconfig' 'frei0r-plugins' 'fribidi
'sdl' 'speex' 'rtmpdump' 'shine' 'twolame' 'v4l-utils' 'vid.stab'
'vo-aacenc' 'vo-amrwbenc' 'xvidcore' 'wavpack' 'zeromq' 'zlib' 'zvbi'
'libvorbisenc.so' 'libvorbis.so' 'libvpx.so' 'libx264.so' 'libx265.so')
-makedepends=('libvdpau' 'yasm' 'hardening-wrapper' 'opencl-headers')
+makedepends=('hardening-wrapper' 'libvdpau' 'nvenc-api' 'opencl-headers' 'yasm')
optdepends=('avxsynth-git: for Avisynth support'
+ 'cuda: for CUDA support'
'opencl-nvidia: for OpenCL support')
conflicts=('ffmpeg' 'ffmpeg-full' 'ffmpeg-git' 'ffmpeg-full-git' 'ffmpeg-full-extra')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'