summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2016-12-08 18:22:20 +0500
committerDmitry Kharitonov2016-12-08 18:22:20 +0500
commit45ae0f760bc56e8cd02a3ac47ce9ee0f19a7e86c (patch)
treeee2fe01f4a9a9263b3141e3dcbd5c5abcfb9cdcf
parent2bd16bfac2ffa162e7b76d5edd794147b1a6dedf (diff)
downloadaur-45ae0f760bc56e8cd02a3ac47ce9ee0f19a7e86c.tar.gz
Re-enabling chromaprint support
Merged the upstream patch (http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=581f93f37ef2e7a00662828ed0348d1edb9041fe#patch1)
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
-rw-r--r--chromaprint1.4.patch16
3 files changed, 33 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52c4df583916..88c888cbd8de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 8 07:12:04 UTC 2016
+# Thu Dec 8 13:21:57 UTC 2016
pkgbase = ffmpeg-full-nvenc
pkgdesc = Record, convert, and stream audio and video (all codecs including Nvidia NVENC)
pkgver = 3.2.2
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = http://ffmpeg.org/
arch = i686
@@ -17,6 +17,7 @@ pkgbase = ffmpeg-full-nvenc
depends = alsa-lib
depends = bzip2
depends = celt
+ depends = chromaprint-fftw
depends = flite
depends = fontconfig
depends = frei0r-plugins
@@ -111,9 +112,11 @@ pkgbase = ffmpeg-full-nvenc
source = https://ffmpeg.org/releases/ffmpeg-3.2.2.tar.xz
source = https://ffmpeg.org/releases/ffmpeg-3.2.2.tar.xz.asc
source = UNREDISTRIBUTABLE.txt
+ source = chromaprint1.4.patch
sha256sums = 3f01bd1fe1a17a277f8c84869e5d9192b4b978cb660872aa2b54c3cc8a2fedfc
sha256sums = SKIP
sha256sums = e0c1b126862072a71e18b9580a6b01afc76a54aa6e642d2c413ba0ac9d3010c4
+ sha256sums = 0fd1fa85ed784191b20683e9309a4ac7e4464249de13fe42676e2445320afb94
depends_x86_64 = cuda
optdepends_x86_64 = intel-media-sdk: for Intel QSV support (Experimental! See PKGBUILD of that package for additional info)
diff --git a/PKGBUILD b/PKGBUILD
index 2400fbbb67f3..0217f902d5e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,13 +23,13 @@
pkgname=ffmpeg-full-nvenc
_pkgbasename=ffmpeg
pkgver=3.2.2
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="Record, convert, and stream audio and video (all codecs including Nvidia NVENC)"
arch=('i686' 'x86_64')
url="http://ffmpeg.org/"
license=('GPL' 'custom:UNREDISTRIBUTABLE')
-depends=('alsa-lib' 'bzip2' 'celt' 'flite' 'fontconfig' 'frei0r-plugins'
+depends=('alsa-lib' 'bzip2' 'celt' 'chromaprint-fftw' 'flite' 'fontconfig' 'frei0r-plugins'
'fribidi' 'glibc' 'gnutls' 'gsm' 'jack' 'kvazaar' 'ladspa' 'lame' 'libass'
'libavc1394' 'libbluray' 'libbs2b' 'libcaca' 'libcdio-paranoia' 'libdc1394'
'libebur128' 'libfdk-aac' 'libgme' 'libiec61883' 'libilbc' 'libmfx-git'
@@ -51,11 +51,18 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
'libswscale.so' 'ffmpeg' 'qt-faststart')
source=(https://ffmpeg.org/releases/$_pkgbasename-$pkgver.tar.xz{,.asc}
- 'UNREDISTRIBUTABLE.txt')
+ 'UNREDISTRIBUTABLE.txt'
+ 'chromaprint1.4.patch')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
sha256sums=('3f01bd1fe1a17a277f8c84869e5d9192b4b978cb660872aa2b54c3cc8a2fedfc'
'SKIP'
- 'e0c1b126862072a71e18b9580a6b01afc76a54aa6e642d2c413ba0ac9d3010c4')
+ 'e0c1b126862072a71e18b9580a6b01afc76a54aa6e642d2c413ba0ac9d3010c4'
+ '0fd1fa85ed784191b20683e9309a4ac7e4464249de13fe42676e2445320afb94')
+
+prepare() {
+ cd "$_pkgbasename-$pkgver"
+ patch -p1 < ../chromaprint1.4.patch
+}
build() {
cd $_pkgbasename-$pkgver
@@ -109,7 +116,7 @@ build() {
\
--enable-avisynth \
--enable-audiotoolbox \
- --disable-chromaprint \
+ --enable-chromaprint \
--enable-decoder=atrac3 \
--enable-decoder=atrac3p \
--enable-bzlib \
diff --git a/chromaprint1.4.patch b/chromaprint1.4.patch
new file mode 100644
index 000000000000..328ab9d333b6
--- /dev/null
+++ b/chromaprint1.4.patch
@@ -0,0 +1,16 @@
+diff --git a/libavformat/chromaprint.c b/libavformat/chromaprint.c
+index 8c9a6c0..4da02be 100644
+--- a/libavformat/chromaprint.c
++++ b/libavformat/chromaprint.c
+@@ -39,7 +39,11 @@ typedef struct ChromaprintMuxContext {
+ int silence_threshold;
+ int algorithm;
+ FingerprintFormat fp_format;
++#if CPR_VERSION_INT >= AV_VERSION_INT(1, 4, 0)
++ ChromaprintContext *ctx;
++#else
+ ChromaprintContext ctx;
++#endif
+ } ChromaprintMuxContext;
+
+ static void cleanup(ChromaprintMuxContext *cpr)