summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Kharitonov2019-05-04 19:06:54 +0500
committerDmitry Kharitonov2019-05-04 19:06:54 +0500
commit64fc61afe9e2a574c78b05f5177a4513ae16b4a4 (patch)
treeff77e283aeb8987924d441bc39cd63c4ce951eb1
parenta905bcda238ae947317f66f9fd54ed5d94e41fed (diff)
downloadaur-64fc61afe9e2a574c78b05f5177a4513ae16b4a4.tar.gz
Temporarily disabling kvazaar; fixed tensorflow path
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19f3052b2056..0e509e5b228a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-full-nvenc
pkgdesc = Record, convert, and stream audio and video (all codecs including Nvidia NVENC)
pkgver = 4.1.3
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://ffmpeg.org/
arch = i686
@@ -27,7 +27,6 @@ pkgbase = ffmpeg-full-nvenc
depends = glibc
depends = gsm
depends = jack
- depends = kvazaar
depends = ladspa
depends = lame
depends = lensfun
diff --git a/PKGBUILD b/PKGBUILD
index 83f2e2632bac..8a647d97170f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,14 +25,14 @@
pkgname=ffmpeg-full-nvenc
_pkgbasename=ffmpeg
pkgver=4.1.3
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Record, convert, and stream audio and video (all codecs including Nvidia NVENC)"
arch=('i686' 'x86_64')
url="http://ffmpeg.org/"
license=('custom: nonfree and unredistributable')
depends=('alsa-lib' 'aom' 'bzip2' 'celt' 'chromaprint-fftw' 'codec2' 'davs2' 'fontconfig'
- 'ffnvcodec-headers' 'frei0r-plugins' 'fribidi' 'glibc' 'gsm' 'jack' 'kvazaar'
+ 'ffnvcodec-headers' 'frei0r-plugins' 'fribidi' 'glibc' 'gsm' 'jack'
'ladspa' 'lame' 'lensfun' 'libass' 'libavc1394' 'libbluray' 'libbs2b' 'libcaca'
'libcdio-paranoia' 'libdc1394' 'libfdk-aac' 'libgme' 'libiec61883'
'libilbc' 'libmodplug' 'libomxil-bellagio' 'libmysofa' 'libpulse'
@@ -81,6 +81,11 @@ build() {
fi
local _ldflags="-L/opt/cuda/lib64 ${_nvidia_340xx_ldflags}"
local _ldflags="${_ldflags} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64:/opt/intel/mediasdk/plugins"
+
+ # fix tensorflow include dir
+ ## upstream ffmpeg excects : /usr/include/tensorflow/
+ ## tensorflow package ships: /usr/include/tensorflow/tensorflow/
+ _cflags+=' -I/usr/include/tensorflow'
# strictly specifying nvcc path is needed if package is installing
# cuda for the first time (nvcc path will be in $PATH only after relogin)
@@ -155,7 +160,7 @@ build() {
--enable-libilbc \
--enable-libjack \
--enable-libklvanc \
- --enable-libkvazaar \
+ --disable-libkvazaar \
--enable-liblensfun \
--enable-libmodplug \
--enable-libmp3lame \