summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-05-13 15:42:23 +0000
committerDaniel Bermond2018-05-13 15:42:23 +0000
commit74da22f6b4e379a7b0d36df7602cebe4a7c943bd (patch)
tree965a4be648444446786262a548927e380c6b7467
parent70efbb43ced05e599388c523bcf7a0a37ee09b39 (diff)
downloadaur-74da22f6b4e379a7b0d36df7602cebe4a7c943bd.tar.gz
Match latest repository changes (notably nvidia hwaccel support)
Changes to match ffmpeg from official repository package in its 1:4.0-2 update: - add support for nvdec/nvenc/cuda/cuvid hardware acceleration by adding ffnvcodec-headers - remove jack support - remove avisynth - add libdrm - improve xlib dependencies by adding libxv and libxext References ---------- https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/ffmpeg&id=ccdc194edaa4617bc8730a48d62f1665cb23acc1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad89429debdd..9d0f268767f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = ffmpeg-git
pkgdesc = Complete solution to record, convert and stream audio and video (git version)
- pkgver = 4.1.r90921.ga150b2e3a0
+ pkgver = 4.1.r91072.gcae004cabb
pkgrel = 1
url = http://www.ffmpeg.org/
arch = i686
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = ffnvcodec-headers
makedepends = ladspa
makedepends = nasm
depends = alsa-lib
@@ -17,11 +18,12 @@ pkgbase = ffmpeg-git
depends = gmp
depends = gnutls
depends = gsm
- depends = jack
depends = lame
depends = libavc1394
+ depends = libdrm
depends = libiec61883
depends = libmodplug
+ depends = libomxil-bellagio
depends = libpulse
depends = libraw1394
depends = libsoxr
@@ -31,7 +33,9 @@ pkgbase = ffmpeg-git
depends = libwebp
depends = libx11
depends = libxcb
+ depends = libxext
depends = libxml2
+ depends = libxv
depends = opencore-amr
depends = openjpeg2
depends = opus
@@ -40,7 +44,6 @@ pkgbase = ffmpeg-git
depends = v4l-utils
depends = xz
depends = zlib
- depends = libomxil-bellagio
depends = libass.so
depends = libbluray.so
depends = libfreetype.so
diff --git a/PKGBUILD b/PKGBUILD
index 45080bf5b9e2..e43356450b9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,22 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=4.1.r90921.ga150b2e3a0
+pkgver=4.1.r91072.gcae004cabb
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
arch=('i686' 'x86_64')
url='http://www.ffmpeg.org/'
license=('GPL3')
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
- 'jack' 'lame' 'libavc1394' 'libiec61883' 'libmodplug' 'libpulse'
- 'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libvdpau' 'libwebp'
- 'libx11' 'libxcb' 'libxml2' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2'
- 'speex' 'v4l-utils' 'xz' 'zlib'
- 'libomxil-bellagio'
+ 'lame' 'libavc1394' 'libdrm' 'libiec61883' 'libmodplug'
+ 'libomxil-bellagio' 'libpulse' 'libraw1394' 'libsoxr' 'libssh'
+ 'libtheora' 'libvdpau' 'libwebp' 'libx11' 'libxcb' 'libxext' 'libxml2'
+ 'libxv' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2' 'speex' 'v4l-utils'
+ 'xz' 'zlib'
'libass.so' 'libbluray.so' 'libfreetype.so' 'libva-drm.so' 'libva.so'
'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so'
'libvpx.so' 'libx264.so' 'libx265.so' 'libxvidcore.so')
-makedepends=('git' 'ladspa' 'nasm')
+makedepends=('git' 'ffnvcodec-headers' 'ladspa' 'nasm')
optdepends=('ladspa: LADSPA filters')
provides=('ffmpeg' 'qt-faststart' 'libavcodec.so' 'libavdevice.so' 'libavfilter.so'
'libavformat.so' 'libavresample.so' 'libavutil.so' 'libpostproc.so'
@@ -50,7 +50,6 @@ build() {
--disable-debug \
--disable-static \
--disable-stripping \
- --enable-avisynth \
--enable-avresample \
--enable-fontconfig \
--enable-gmp \
@@ -59,6 +58,7 @@ build() {
--enable-ladspa \
--enable-libass \
--enable-libbluray \
+ --enable-libdrm \
--enable-libfreetype \
--enable-libfribidi \
--enable-libgsm \
@@ -84,9 +84,11 @@ build() {
--enable-libxcb \
--enable-libxml2 \
--enable-libxvid \
+ --enable-nvdec \
+ --enable-nvenc \
+ --enable-omx \
--enable-shared \
- --enable-version3 \
- --enable-omx
+ --enable-version3
make
make tools/qt-faststart
@@ -98,4 +100,4 @@ package() {
make DESTDIR="$pkgdir" install
install -D -m755 tools/qt-faststart "${pkgdir}/usr/bin/qt-faststart"
-}
+}