summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Tobias2016-12-19 17:06:51 +1100
committerDaniel Tobias2016-12-19 17:06:51 +1100
commit306281ad74c70ab8eb1c2fe59f4b2ae3f9f13e30 (patch)
treeed085b12ad664e58e71122b72682cd157eabdffa
parentdeaa27cff36b66486bded49ac6afefd1931f700d (diff)
downloadaur-306281ad74c70ab8eb1c2fe59f4b2ae3f9f13e30.tar.gz
add back vaapi support via libva-headless
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93b5fe2935b1..9657d0b753fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Dec 7 10:55:34 UTC 2016
+# Mon Dec 19 06:06:17 UTC 2016
pkgbase = ffmpeg-headless
pkgdesc = Complete solution to record, convert and stream audio and video; optimised for server (headless) systems
pkgver = 3.2.2
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://ffmpeg.org/
arch = i686
@@ -23,6 +23,7 @@ pkgbase = ffmpeg-headless
depends = lame
depends = libmodplug
depends = libtheora
+ depends = libva-headless
depends = libwebp
depends = opencore-amr
depends = openjpeg2
@@ -41,12 +42,6 @@ pkgbase = ffmpeg-headless
depends = libx265.so
depends = libxvidcore.so
depends = rtmpdump
- optdepends = vid.stab: Video stabilization library
- optdepends = libfdk-aac: AAC-HE support
- optdepends = libiec61883: FireWire DV/HDV support
- optdepends = libavc1394: FireWire DV/HDV support
- optdepends = netcdf: Binaural listening support
- optdepends = libsoxr: SoX resampler library
provides = libavcodec.so
provides = libavdevice.so
provides = libavfilter.so
diff --git a/PKGBUILD b/PKGBUILD
index 463108cc8aa0..62cb12103d73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_pkgname=ffmpeg
pkgname=ffmpeg-headless
pkgver=3.2.2
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video; optimised for server (headless) systems'
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
@@ -16,19 +16,13 @@ url='http://ffmpeg.org/'
license=('GPL3') #enabling libfdk_aac makes ffmpeg incompatible with the GPL!
depends=('bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
'lame' 'libmodplug'
- 'libtheora'
+ 'libtheora' 'libva-headless'
'libwebp' 'opencore-amr' 'openjpeg2' 'opus'
'schroedinger' 'speex' 'v4l-utils' 'xz' 'zlib'
'libass.so' 'libbluray.so'
'libvorbisenc.so' 'libvorbis.so' 'libvpx.so'
'libx264.so' 'libx265.so' 'libxvidcore.so'
'rtmpdump')
-optdepends=('vid.stab: Video stabilization library'
- 'libfdk-aac: AAC-HE support'
- 'libiec61883: FireWire DV/HDV support'
- 'libavc1394: FireWire DV/HDV support'
- 'netcdf: Binaural listening support'
- 'libsoxr: SoX resampler library')
makedepends=('hardening-wrapper' 'yasm')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
@@ -73,6 +67,7 @@ build() {
--enable-libx265 \
--enable-libxvid \
--enable-shared \
+ --enable-vaapi \
--enable-version3 \
--enable-librtmp \
--enable-runtime-cpudetect \
@@ -81,7 +76,6 @@ build() {
--disable-fontconfig \
--disable-libfreetype \
--disable-vdpau \
- --disable-vaapi \
--disable-htmlpages #\
#--enable-libiec61883
#--enable-libsoxr \