summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Tobias2016-05-22 23:06:29 +1000
committerDaniel Tobias2016-05-22 23:06:29 +1000
commitf971365035535241a635d1c0c5a23ae6f0dcf2c4 (patch)
tree6f6320b08c4257d3b88267050181485741447f0e
parentc7fb60cbf422434edf90ac2b122783102589f9a4 (diff)
downloadaur-f971365035535241a635d1c0c5a23ae6f0dcf2c4.tar.gz
add more optional deps for those that want to uncomment more build options
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09132e48581b..6aac50b5a75c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Apr 30 02:59:53 UTC 2016
+# Sun May 22 13:06:01 UTC 2016
pkgbase = ffmpeg-headless
pkgdesc = Complete solution to record, convert and stream audio and video; optimised for server (headless) systems
pkgver = 3.0.2
@@ -37,9 +37,13 @@ pkgbase = ffmpeg-headless
depends = libx264.so
depends = libx265.so
depends = rtmpdump
- optdepends = libdcadec.so
- optdepends = libvidstab.so
- optdepends = libfdk-aac
+ optdepends = dcadec: DTS Coherent Acoustics support
+ optdepends = vid.stab: Video stabilization library
+ optdepends = libfdk-aac: AAC-HE support
+ optdepends = libiec61883: FireWire DV/HDV support
+ optdepends = libavc1394: FireWire DV/HDV support
+ optdepends = netcdf: Binaural listening support
+ optdepends = libsoxr: SoX resampler library
provides = libavcodec.so
provides = libavdevice.so
provides = libavfilter.so
diff --git a/PKGBUILD b/PKGBUILD
index f8c38575bf03..fec7b863aa5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,13 @@ depends=('bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame' 'libass'
'openjpeg' 'opus' 'schroedinger' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
'libvorbis.so' 'libvorbisenc.so' 'libvpx.so' 'libx264.so' 'libx265.so'
'rtmpdump')
-optdepends=('libdcadec.so' 'libvidstab.so' 'libfdk-aac')
+optdepends=('dcadec: DTS Coherent Acoustics support'
+ 'vid.stab: Video stabilization library'
+ 'libfdk-aac: AAC-HE support'
+ 'libiec61883: FireWire DV/HDV support'
+ 'libavc1394: FireWire DV/HDV support'
+ 'netcdf: Binaural listening support'
+ 'libsoxr: SoX resampler library')
makedepends=('hardening-wrapper' 'yasm')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
@@ -68,7 +74,10 @@ build() {
--enable-librtmp \
--enable-runtime-cpudetect #\
#--enable-libdcadec \
+ #--enable-libiec61883
+ #--enable-libsoxr \
#--enable-libvidstab \
+ #--enable-netcdf \
#--enable-libfdk_aac \
#--enable-nonfree