summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Tobias2016-02-13 04:28:29 +1100
committerDaniel Tobias2016-02-13 04:28:29 +1100
commitb925731ec2d468ccfc91dbf78050fedd1eeb11ec (patch)
treed63d8552359b3b945b1c26cb09c17c03cb375bcd
parentb97aa8bc72a0b5d33f60321cd4f562eb46b911ab (diff)
downloadaur-b925731ec2d468ccfc91dbf78050fedd1eeb11ec.tar.gz
add optdepends, PKGBUILD has to be manualy edited and package rebuilt to use them.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be3bb052a20a..dcdcc23a9764 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Feb 3 01:22:13 UTC 2016
+# Fri Feb 12 17:28:03 UTC 2016
pkgbase = ffmpeg-headless
pkgdesc = Complete solution to record, convert and stream audio and video; optimised for server (headless) systems
pkgver = 2.8.6
@@ -37,6 +37,9 @@ pkgbase = ffmpeg-headless
depends = libx264.so
depends = libx265.so
depends = rtmpdump
+ optdepends = libdcadec.so
+ optdepends = libvidstab.so
+ optdepends = libfdk-aac
provides = libavcodec.so
provides = libavdevice.so
provides = libavfilter.so
diff --git a/PKGBUILD b/PKGBUILD
index 63efdf0f63d4..97d744f450c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# $Id$
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
@@ -13,12 +13,13 @@ epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video; optimised for server (headless) systems'
arch=('i686' 'x86_64' 'armv7h')
url='http://ffmpeg.org/'
-license=('GPL3')
+license=('GPL3') #enabling libfdk_aac makes ffmpeg incompatible with the GPL!
depends=('bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame' 'libass'
'libbluray' 'libmodplug' 'libtheora' 'libwebp' 'opencore-amr'
'openjpeg' 'opus' 'schroedinger' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
'libvorbis.so' 'libvorbisenc.so' 'libvpx.so' 'libx264.so' 'libx265.so'
'rtmpdump')
+optdepends=('libdcadec.so' 'libvidstab.so' 'libfdk-aac')
makedepends=('hardening-wrapper' 'yasm')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
@@ -65,7 +66,11 @@ build() {
--enable-shared \
--enable-version3 \
--enable-librtmp \
- --enable-runtime-cpudetect
+ --enable-runtime-cpudetect #\
+ #--enable-libdcadec \
+ #--enable-libvidstab \
+ #--enable-libfdk_aac \
+ #--enable-nonfree
make
make doc/ff{mpeg,play,server}.1