summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Widawsky2020-12-27 19:40:41 -0800
committerBen Widawsky2020-12-27 19:42:55 -0800
commit259fe3e6f05e66b90a2f3e154d61df03f4c1f9cd (patch)
tree4a32c74a582a6fc3422daa016dbfcf27dfa916f2
parentc0395b2c6b91ae9664c5bcdb3cb32b3893e3e472 (diff)
downloadaur-259fe3e6f05e66b90a2f3e154d61df03f4c1f9cd.tar.gz
Update to latest upstream
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--fix-8760.patch29
3 files changed, 11 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 838910c4e329..5d5dc7b8ceb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = ffmpeg-libfdk_aac
pkgdesc = Complete solution to record, convert and stream audio and video (Same as official package except with libfdk-aac support)
pkgver = 4.3.1
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://ffmpeg.org/
arch = x86_64
license = GPL3
license = custom:libfdk-aac
+ makedepends = amf-headers
makedepends = avisynthplus
+ makedepends = clang
makedepends = ffnvcodec-headers
makedepends = git
makedepends = ladspa
@@ -30,7 +32,6 @@ pkgbase = ffmpeg-libfdk_aac
depends = libiec61883
depends = libmfx
depends = libmodplug
- depends = libomxil-bellagio
depends = libpulse
depends = librav1e.so
depends = libraw1394
@@ -82,10 +83,8 @@ pkgbase = ffmpeg-libfdk_aac
conflicts = ffmpeg
source = git+https://git.ffmpeg.org/ffmpeg.git#tag=6b6b9e593dd4d3aaf75f48d40a13ef03bdef9fdb
source = vmaf-model-path.patch
- source = fix-8760.patch
sha256sums = SKIP
sha256sums = 8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d
- sha256sums = 0dd0fbeb8bc67eb2c3d1376cca4a95e708e2dce48d3bc33a77fac2b9867af9e6
pkgname = ffmpeg-libfdk_aac
diff --git a/PKGBUILD b/PKGBUILD
index a0c4b72cf82f..4db36922827d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_name=ffmpeg
pkgname=ffmpeg-libfdk_aac
pkgver=4.3.1
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video (Same as official package except with libfdk-aac support)'
arch=(x86_64)
@@ -35,7 +35,6 @@ depends=(
libiec61883
libmfx
libmodplug
- libomxil-bellagio
libpulse
librav1e.so
libraw1394
@@ -73,7 +72,9 @@ depends=(
libfdk-aac
)
makedepends=(
+ amf-headers
avisynthplus
+ clang
ffnvcodec-headers
git
ladspa
@@ -101,11 +102,9 @@ conflicts=("$_name")
source=(
git+https://git.ffmpeg.org/ffmpeg.git#tag=${_tag}
vmaf-model-path.patch
- fix-8760.patch
)
sha256sums=('SKIP'
- '8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d'
- '0dd0fbeb8bc67eb2c3d1376cca4a95e708e2dce48d3bc33a77fac2b9867af9e6')
+ '8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d')
pkgver() {
cd ffmpeg
@@ -115,8 +114,8 @@ pkgver() {
prepare() {
cd ffmpeg
+ git cherry-pick -n 7c59e1b0f285cd7c7b35fcd71f49c5fd52cf9315 # fix build against libsrt 1.4.2
patch -Np1 -i "${srcdir}"/vmaf-model-path.patch
- patch -Np1 -i "${srcdir}"/fix-8760.patch
}
build() {
cd ffmpeg
@@ -126,7 +125,10 @@ build() {
--disable-debug \
--disable-static \
--disable-stripping \
+ --enable-amf \
--enable-avisynth \
+ --enable-cuda-llvm \
+ --enable-lto \
--enable-fontconfig \
--enable-gmp \
--enable-gpl \
diff --git a/fix-8760.patch b/fix-8760.patch
deleted file mode 100644
index ced7bfc76f58..000000000000
--- a/fix-8760.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/libavformat/libsrt.c b/libavformat/libsrt.c
-index 4de575b37c..4719ce0d4b 100644
---- a/libavformat/libsrt.c
-+++ b/libavformat/libsrt.c
-@@ -313,8 +313,12 @@ static int libsrt_set_options_pre(URLContext *h, int fd)
- (s->pbkeylen >= 0 && libsrt_setsockopt(h, fd, SRTO_PBKEYLEN, "SRTO_PBKEYLEN", &s->pbkeylen, sizeof(s->pbkeylen)) < 0) ||
- (s->passphrase && libsrt_setsockopt(h, fd, SRTO_PASSPHRASE, "SRTO_PASSPHRASE", s->passphrase, strlen(s->passphrase)) < 0) ||
- #if SRT_VERSION_VALUE >= 0x010302
-+#if SRT_VERSION_VALUE >= 0x010401
-+ (s->enforced_encryption >= 0 && libsrt_setsockopt(h, fd, SRTO_ENFORCEDENCRYPTION, "SRTO_ENFORCEDENCRYPTION", &s->enforced_encryption, sizeof(s->enforced_encryption)) < 0) ||
-+#else
- /* SRTO_STRICTENC == SRTO_ENFORCEDENCRYPTION (53), but for compatibility, we used SRTO_STRICTENC */
- (s->enforced_encryption >= 0 && libsrt_setsockopt(h, fd, SRTO_STRICTENC, "SRTO_STRICTENC", &s->enforced_encryption, sizeof(s->enforced_encryption)) < 0) ||
-+#endif
- (s->kmrefreshrate >= 0 && libsrt_setsockopt(h, fd, SRTO_KMREFRESHRATE, "SRTO_KMREFRESHRATE", &s->kmrefreshrate, sizeof(s->kmrefreshrate)) < 0) ||
- (s->kmpreannounce >= 0 && libsrt_setsockopt(h, fd, SRTO_KMPREANNOUNCE, "SRTO_KMPREANNOUNCE", &s->kmpreannounce, sizeof(s->kmpreannounce)) < 0) ||
- #endif
-@@ -333,7 +337,11 @@ static int libsrt_set_options_pre(URLContext *h, int fd)
- (s->lossmaxttl >= 0 && libsrt_setsockopt(h, fd, SRTO_LOSSMAXTTL, "SRTO_LOSSMAXTTL", &s->lossmaxttl, sizeof(s->lossmaxttl)) < 0) ||
- (s->minversion >= 0 && libsrt_setsockopt(h, fd, SRTO_MINVERSION, "SRTO_MINVERSION", &s->minversion, sizeof(s->minversion)) < 0) ||
- (s->streamid && libsrt_setsockopt(h, fd, SRTO_STREAMID, "SRTO_STREAMID", s->streamid, strlen(s->streamid)) < 0) ||
-+#if SRT_VERSION_VALUE >= 0x010401
-+ (s->smoother && libsrt_setsockopt(h, fd, SRTO_CONGESTION, "SRTO_CONGESTION", s->smoother, strlen(s->smoother)) < 0) ||
-+#else
- (s->smoother && libsrt_setsockopt(h, fd, SRTO_SMOOTHER, "SRTO_SMOOTHER", s->smoother, strlen(s->smoother)) < 0) ||
-+#endif
- (s->messageapi >= 0 && libsrt_setsockopt(h, fd, SRTO_MESSAGEAPI, "SRTO_MESSAGEAPI", &s->messageapi, sizeof(s->messageapi)) < 0) ||
- (s->payload_size >= 0 && libsrt_setsockopt(h, fd, SRTO_PAYLOADSIZE, "SRTO_PAYLOADSIZE", &s->payload_size, sizeof(s->payload_size)) < 0) ||
- ((h->flags & AVIO_FLAG_WRITE) && libsrt_setsockopt(h, fd, SRTO_SENDER, "SRTO_SENDER", &yes, sizeof(yes)) < 0)) {