summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrédéric Mangano-Tarumi2020-01-05 20:00:00 -0500
committerFrédéric Mangano-Tarumi2020-01-05 20:00:00 -0500
commit2f97fa0b97598f969ef0f311b299b4c9ddcc0843 (patch)
treeaa556fabb7697df03945dfb332cf00ca087ef62d
parent63292693f59162fde4896b6253eacbbaf4474f3a (diff)
downloadaur-2f97fa0b97598f969ef0f311b299b4c9ddcc0843.tar.gz
ffmpeg 4.2.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea47d25a2d97..078e67f0317a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 20 00:17:04 UTC 2019
+# Mon Jan 6 00:59:58 UTC 2020
pkgbase = ffmpeg-mmal
pkgdesc = ffmpeg built with MMAL hardware acceleration support for Raspberry Pi
- pkgver = 4.2
+ pkgver = 4.2.1
pkgrel = 1
epoch = 1
url = https://ffmpeg.org/
@@ -73,7 +73,7 @@ pkgbase = ffmpeg-mmal
provides = libswresample.so
provides = libswscale.so
conflicts = ffmpeg
- source = git+https://git.ffmpeg.org/ffmpeg.git#tag=n4.2
+ source = git+https://git.ffmpeg.org/ffmpeg.git#commit=cbb3c9497549f8856d8cd37ac63af1406a784e58
sha256sums = SKIP
pkgname = ffmpeg-mmal
diff --git a/PKGBUILD b/PKGBUILD
index b85adc4c73b1..ebceabdd872f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,8 @@
# Upstream: https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/master/extra/ffmpeg/PKGBUILD
pkgname=ffmpeg-mmal
-pkgver=4.2
+_gitcommit=cbb3c9497549f8856d8cd37ac63af1406a784e58
+pkgver=4.2.1
pkgrel=1
epoch=1
pkgdesc='ffmpeg built with MMAL hardware acceleration support for Raspberry Pi'
@@ -87,9 +88,21 @@ provides=(
libswresample.so
libswscale.so
)
-source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver})
conflicts=('ffmpeg')
-sha256sums=('SKIP')
+source=("git+https://git.ffmpeg.org/ffmpeg.git#commit=${_gitcommit}")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ffmpeg
+
+ git describe --tags | sed 's/^n//'
+}
+
+prepare() {
+ cd ffmpeg
+
+ git cherry-pick -n dc0806dd25882f41f6085c8356712f95fded56c7
+}
build() {
cd ffmpeg
@@ -97,7 +110,7 @@ build() {
[[ $CARCH == "armv7h" || $CARCH == "aarch64" ]] && CONFIG='--host-cflags="-fPIC"'
./configure \
- --prefix='/usr' \
+ --prefix=/usr \
--disable-debug \
--disable-static \
--disable-stripping \