summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrédéric Mangano-Tarumi2016-09-14 08:49:33 +0200
committerFrédéric Mangano-Tarumi2016-09-14 11:43:11 +0200
commit9c81964fee1886aa023fc67107d94e2a01cf1ef0 (patch)
treecef624da021f896fbab9ebad64fb73ae170b32cc
downloadaur-9c81964fee1886aa023fc67107d94e2a01cf1ef0.tar.gz
ffmpeg-mmal 3.0
-rw-r--r--.SRCINFO67
-rw-r--r--PKGBUILD97
2 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffd84f138ef8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,67 @@
+pkgbase = ffmpeg-mmal
+ pkgdesc = Complete solution to record, convert and stream audio and video
+ pkgver = 3.0
+ pkgrel = 1
+ epoch = 1
+ url = http://ffmpeg.org/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL3
+ makedepends = hardening-wrapper
+ makedepends = ladspa
+ makedepends = libvdpau
+ makedepends = yasm
+ depends = alsa-lib
+ depends = bzip2
+ depends = fontconfig
+ depends = fribidi
+ depends = gnutls
+ depends = gsm
+ depends = lame
+ depends = libass
+ depends = libbluray
+ depends = libmodplug
+ depends = libpulse
+ depends = libsoxr
+ depends = libssh
+ depends = libtheora
+ depends = libva
+ depends = libvdpau
+ depends = libwebp
+ depends = opencore-amr
+ depends = openjpeg
+ depends = opus
+ depends = schroedinger
+ depends = sdl
+ depends = speex
+ depends = v4l-utils
+ depends = xvidcore
+ depends = zlib
+ depends = libdcadec.so
+ depends = libvidstab.so
+ depends = libvorbis.so
+ depends = libvorbisenc.so
+ depends = libvpx.so
+ depends = libx264.so
+ depends = libx265.so
+ optdepends = ladspa: LADSPA filters
+ provides = libavcodec.so
+ provides = libavdevice.so
+ provides = libavfilter.so
+ provides = libavformat.so
+ provides = libavresample.so
+ provides = libavutil.so
+ provides = libpostproc.so
+ provides = libswresample.so
+ provides = libswscale.so
+ provides = ffmpeg
+ conflicts = ffmpeg
+ source = http://ffmpeg.org/releases/ffmpeg-3.0.tar.bz2
+ source = http://ffmpeg.org/releases/ffmpeg-3.0.tar.bz2.asc
+ validpgpkeys = FCF986EA15E6E293A5644F10B4322F04D67658D8
+ sha256sums = f19ff77a2f7f736a41dd1499eef4784bf3cb7461f07c13a268164823590113c0
+ sha256sums = SKIP
+
+pkgname = ffmpeg-mmal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f301d9e2e2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,97 @@
+# $Id$
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Paul Mattal <paul@archlinux.org>
+# Contributor: Frédéric Mangano <fmang+aur@mg0.fr>
+
+# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
+# - use -fPIC in host cflags for armv7 to fix print_options.c compile
+
+pkgname=ffmpeg-mmal
+pkgver=3.0
+pkgrel=1
+epoch=1
+pkgdesc='Complete solution to record, convert and stream audio and video'
+arch=('i686' 'x86_64' 'armv7h')
+url='http://ffmpeg.org/'
+license=('GPL3')
+depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame'
+ 'libass' 'libbluray' 'libmodplug' 'libpulse' 'libsoxr' 'libssh'
+ 'libtheora' 'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg'
+ 'opus' 'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
+ 'libdcadec.so' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
+ 'libvpx.so' 'libx264.so' 'libx265.so')
+makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
+optdepends=('ladspa: LADSPA filters')
+provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+ 'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+ 'libswscale.so' 'ffmpeg')
+conflicts=('ffmpeg')
+source=(http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2{,.asc})
+validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
+sha256sums=('f19ff77a2f7f736a41dd1499eef4784bf3cb7461f07c13a268164823590113c0'
+ 'SKIP')
+
+build() {
+ cd ffmpeg-${pkgver}
+
+ [[ $CARCH == "armv7h" || $CARCH == "aarch64" ]] && CONFIG='--host-cflags="-fPIC"'
+
+ ./configure \
+ --prefix='/usr' \
+ --disable-debug \
+ --disable-static \
+ --disable-stripping \
+ --enable-avisynth \
+ --enable-avresample \
+ --enable-fontconfig \
+ --enable-gnutls \
+ --enable-gpl \
+ --enable-ladspa \
+ --enable-libass \
+ --enable-libbluray \
+ --enable-libdcadec \
+ --enable-libfreetype \
+ --enable-libfribidi \
+ --enable-libgsm \
+ --enable-libmodplug \
+ --enable-libmp3lame \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
+ --enable-libopenjpeg \
+ --enable-libopus \
+ --enable-libpulse \
+ --enable-libschroedinger \
+ --enable-libsoxr \
+ --enable-libspeex \
+ --enable-libssh \
+ --enable-libtheora \
+ --enable-libv4l2 \
+ --enable-libvidstab \
+ --enable-libvorbis \
+ --enable-libvpx \
+ --enable-libwebp \
+ --enable-libx264 \
+ --enable-libx265 \
+ --enable-libxvid \
+ --enable-mmal \
+ --enable-shared \
+ --enable-version3 \
+ --enable-x11grab \
+ $CONFIG
+
+ make
+ make tools/qt-faststart
+ make doc/ff{mpeg,play,server}.1
+}
+
+package() {
+ cd ffmpeg-${pkgver}
+
+ make DESTDIR="${pkgdir}" install install-man
+ install -Dm 755 tools/qt-faststart "${pkgdir}"/usr/bin/
+}
+
+# vim: ts=2 sw=2 et: