summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2023-10-02 09:16:33 +0200
committeregnappahz2023-10-02 09:16:33 +0200
commit6580d9b701c79f009410994eebd4f08278fcb1db (patch)
tree09fed3b982cb88a88042294c7b4b531d8f598f62
parente07ab43f9c0ef1b75237b6ee6a172a1399f80888 (diff)
downloadaur-6580d9b701c79f009410994eebd4f08278fcb1db.tar.gz
Updated
-rw-r--r--.SRCINFO8
-rw-r--r--060-ffmpeg-fix-segfault-with-avisynthplus.patch10
-rw-r--r--PKGBUILD39
3 files changed, 42 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b75bfb80fe9c..d8765f6b4ccd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-nocuda
pkgdesc = Complete solution to record, convert and stream audio and video (without nvidias propriatary blobs)
- pkgver = 6.0
- pkgrel = 5
+ pkgver = 6.1
+ pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
license = GPL3
@@ -78,8 +78,10 @@ pkgbase = ffmpeg-nocuda
provides = libswscale.so
provides = ffmpeg
conflicts = ffmpeg
- source = git+https://git.ffmpeg.org/ffmpeg.git#tag=n6.0
+ source = git+https://git.ffmpeg.org/ffmpeg.git
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
+ source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/060-ffmpeg-fix-segfault-with-avisynthplus.patch b/060-ffmpeg-fix-segfault-with-avisynthplus.patch
new file mode 100644
index 000000000000..a753a04e6cee
--- /dev/null
+++ b/060-ffmpeg-fix-segfault-with-avisynthplus.patch
@@ -0,0 +1,10 @@
+--- a/libavformat/avisynth.c
++++ b/libavformat/avisynth.c
+@@ -142,7 +142,7 @@ static av_cold void avisynth_atexit_handler(void);
+
+ static av_cold int avisynth_load_library(void)
+ {
+- avs_library.library = dlopen(AVISYNTH_LIB, RTLD_NOW | RTLD_LOCAL);
++ avs_library.library = dlopen(AVISYNTH_LIB, RTLD_NOW | RTLD_DEEPBIND);
+ if (!avs_library.library)
+ return AVERROR_UNKNOWN;
diff --git a/PKGBUILD b/PKGBUILD
index 7e2168e8b4dc..b176ded34758 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer : eggz
pkgname=ffmpeg-nocuda
-pkgver=6.0
+pkgver=6.1
gitver=n${pkgver}
-pkgrel=5
+pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (without nvidias propriatary blobs)'
arch=('x86_64')
url='https://www.ffmpeg.org/'
@@ -61,7 +61,6 @@ depends=(
'vmaf'
'xz'
'zlib'
-
)
makedepends=('git' 'avisynthplus' 'ffnvcodec-headers' 'ladspa' 'nasm' 'srt')
optdepends=('avisynthplus: for reading AviSynth scripts as input'
@@ -72,12 +71,16 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libswresample.so' 'libswscale.so'
'ffmpeg')
conflicts=('ffmpeg')
-source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=$gitver"
- 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
+source=(
+#"git+https://git.ffmpeg.org/ffmpeg.git#tag=$gitver"
+"git+https://git.ffmpeg.org/ffmpeg.git"
+ '040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
+ '060-ffmpeg-fix-segfault-with-avisynthplus.patch'
)
sha256sums=(
'SKIP'
'SKIP'
+'SKIP'
)
prepare() {
@@ -89,16 +92,13 @@ prepare() {
msg2 "Patching gitsource"
echo "Applying $patch"
- #git apply $patch || exit 2
patch -Np1 -i $patch
done <<< $(ls ../*.patch 2> /dev/null)
}
build() {
- cd ${srcdir}/ffmpeg
-
+ cd ${srcdir}/ffmpeg
printf '%s\n' ' -> Running ffmpeg configure script...'
-
./configure \
--prefix='/usr' \
--disable-debug \
@@ -107,7 +107,14 @@ build() {
--disable-hwaccel=cuda \
--disable-nvdec \
--disable-nvenc \
+ --prefix='/usr' \
+ --disable-debug \
+ --disable-static \
+ --disable-stripping \
+ --enable-amf \
--enable-avisynth \
+ --enable-cuda-llvm \
+ --enable-lto \
--enable-fontconfig \
--enable-gmp \
--enable-gnutls \
@@ -116,6 +123,7 @@ build() {
--enable-libaom \
--enable-libass \
--enable-libbluray \
+ --enable-libbs2b \
--enable-libdav1d \
--enable-libdrm \
--enable-libfreetype \
@@ -123,24 +131,28 @@ build() {
--enable-libgsm \
--enable-libiec61883 \
--enable-libjack \
- --enable-libmfx \
+ --enable-libjxl \
--enable-libmodplug \
--enable-libmp3lame \
--enable-libopencore_amrnb \
--enable-libopencore_amrwb \
--enable-libopenjpeg \
+ --enable-libopenmpt \
--enable-libopus \
--enable-libpulse \
--enable-librav1e \
+ --enable-librsvg \
--enable-libsoxr \
--enable-libspeex \
--enable-libsrt \
--enable-libssh \
+ --enable-libsvtav1 \
--enable-libtheora \
--enable-libv4l2 \
--enable-libvidstab \
--enable-libvmaf \
--enable-libvorbis \
+ --enable-libvpl \
--enable-libvpx \
--enable-libwebp \
--enable-libx264 \
@@ -148,9 +160,12 @@ build() {
--enable-libxcb \
--enable-libxml2 \
--enable-libxvid \
- --enable-omx \
+ --enable-libzimg \
+ --enable-opencl \
+ --enable-opengl \
--enable-shared \
- --enable-version3
+ --enable-version3 \
+ --enable-vulkan
make
make tools/qt-faststart
}