summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-07-17 16:36:31 +0000
committerDaniel Bermond2020-07-17 16:36:31 +0000
commit4ab5f75c4e3050a789b54093f73c6039ba60b246 (patch)
tree06bd7909c97b879dafcbb498fd12b3c967d8cf4c
parentf2b4a6d1b309fdb3d6d2a76f572819dc562e781e (diff)
downloadaur-4ab5f75c4e3050a789b54093f73c6039ba60b246.tar.gz
Match repository package changes
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b628b8f42c0..8bef01edf649 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-git
pkgdesc = Complete solution to record, convert and stream audio and video (git version)
- pkgver = 4.3.r98015.ga886785018
+ pkgver = 4.4.r98491.g3a37aa597f
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -31,6 +31,7 @@ pkgbase = ffmpeg-git
depends = libmodplug
depends = libomxil-bellagio
depends = libpulse
+ depends = librav1e.so
depends = libraw1394
depends = libsoxr
depends = libssh
diff --git a/PKGBUILD b/PKGBUILD
index 49aa468063e0..571e66f29030 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=4.3.r98015.ga886785018
+pkgver=4.4.r98491.g3a37aa597f
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
arch=('x86_64')
@@ -32,6 +32,7 @@ depends=(
'libmodplug'
'libomxil-bellagio'
'libpulse'
+ 'librav1e.so'
'libraw1394'
'libsoxr'
'libssh'
@@ -86,8 +87,8 @@ pkgver() {
local _version
local _revision
local _shorthash
- _version="$(git -C ffmpeg describe --tags --long | awk -F'-' '{ sub(/^n/, "", $1); print $1 }')"
- _revision="$(git -C ffmpeg describe --tags --match 'N' | awk -F'-' '{ print $2 }')"
+ _version="$(git -C ffmpeg describe --tags --long | awk -F'-' '{ sub(/^n/, "", $1); print $1 }')"
+ _revision="$(git -C ffmpeg describe --tags --match 'N' | awk -F'-' '{ print $2 }')"
_shorthash="$(git -C ffmpeg rev-parse --short HEAD)"
printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
@@ -126,6 +127,7 @@ build() {
--enable-libopenjpeg \
--enable-libopus \
--enable-libpulse \
+ --enable-librav1e \
--enable-libsoxr \
--enable-libspeex \
--enable-libsrt \